Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My 10.8.2 MacBook Air is having constant connection errors in Mail.app when the computer has been sent to sleep or hibernate.

A small alert triangle appears next to all account names (I have several) in the sidebar. Mail reception only resumes after quitting and relaunching Mail.app.

I have verified that the net connection is up, and that connections settings and credentials are okay. Similar problems described here.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

This might seem weird and unlikely, but these steps (originally written to restore broken Dictation) fixed it for me:

  1. Go to ~/Library/Preferences ( ++G )
  2. Locate com.apple.assistant.plist and move it to the Trash
  3. Open Dictation & Speech preference panel, disable dictation
  4. Reboot
  5. Re-enable Dictation & Speech.

Any hints on why this is working are very welcome!

share|improve this answer
    
Worked for me too, thanks. The steps here should be quit/launch Mail instead of Dictation. –  Semyon Perepelitsa Sep 20 '13 at 18:33
add comment

It's an SSL issue that takes a few steps to fix.

1) Go to the ISP of each email account and find the actual server name for your account. Change your incoming and outgoing email servers from mailorpop.mydomain.com to mailorpop.servername.com. The server name often has a number in it. (e.g. mail.xserver356.com) Do this for each account.

2) Quit Mac Mail. Open Keychain Access (Applications --> Utilities). At the left click on Logins, then below click on Certificates. Find all email certificates, hold the option key down while clicking on them, then select Delete to get rid of them. Quit Keychain Access.

3) Open Mac Mail. For each account, you will be asked to enter your password again. Click on the Certificate button at the bottom of the window, click the Trust triangle, then check Always Trust. Do this for all incoming email. Then send a test email from each account, and do this process for all outgoing email.

4) Open Keychain Access and find your new login certificates. Double click each one, then click the Trust triangle, and select Always Trust on the top scrollbar. Close the window and enter your keychain password to Update. Do this for each email certificate.

It's a pain in the neck, but after all this, your email should work fine with again with SSL.

share|improve this answer
1  
Could you explain a bit more what you mean with item number one? "Change your incoming and outgoing email servers from mailorpop.mydomain.com to mailorpop.servername.com" ... I don’t get what is to be changed here actually. Thanks! –  myhd Mar 10 '13 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.