Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I bought a brand new MacBook Air from the apple store in Sydney last week, but no matter where I go to connect to a wifi source, it never connects. Wherever I try an exclamation mark shows up and I don't know why this is. I've tried a few things in the system preferences but still unsure. Can someone please help me??

share|improve this question
add comment

1 Answer 1

I wrote an extensive post on MacBook Air wifi issues:

http://apple.stackexchange.com/a/70605/34078

It's not exactly your symptoms, but a good start.

Take a look at the wifi equipment you are trying to attach to. If you can't still get a connection after reading my previous post, take the MBA back to the Apple store and see if you can connect there. If you connect, the issue probably sits with your wifi router. If you cannot connect, it's the laptop.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.