Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I was used to download PDF from Firefox and open them with Preview PDF.

Yesterday I installed Adobe Reader and now each time I click on a PDF link Firefox tries to open the PDF with Abode Reader. And it doesn't work even. See the picture below.

enter image description here

How can I go back to the previous behavior?

share|improve this question
1  
Does it add any add ons? If yes, delete them. By the way, why in the name of God did you install Adobe Reader?! –  duci9y Dec 17 '12 at 18:05
1  
@duci9y ahaha you are right! Did it because it was suggested by a website for reading one of their document that cannot be viewed correctly with preview... –  Maverik Dec 17 '12 at 22:49
    
@duci9y No plugins and neither add-ons. –  Maverik Dec 17 '12 at 22:55
add comment

1 Answer 1

up vote 5 down vote accepted

1st thing to try

  1. Open Firefox
  2. Open Preferences (Firefox > Preferences, or Command + ,)
  3. Select the Applications tab
  4. Search for "pdf"
  5. Change action to something else, then change it back to "Always Ask" visual help

Verify this is set correctly

  1. Open Finder
  2. Search for .pdf
  3. Right (Option) Click the first PDF that appears.
  4. Click Get Info
  5. Expand Open With (if it isn't already)
  6. Change it to "Preview"
  7. Click Change All button below the drop down menu
  8. Accept the prompt.

For a visual representation: step 1 step 2 step 3

share|improve this answer
    
It is already set in this way. That doesn't fix the problem. It's firefox that tries to use Adobe Reader. –  Maverik Dec 17 '12 at 22:51
1  
Check Firefox Settings > Applications then. See if PDF is in that list. –  bassplayer7 Dec 17 '12 at 23:00
    
That made the trick. I already checked it and it was already setted to "Always ask". Now I changed it and re-changed again and it fixed the problem. Can you update your answer please? –  Maverik Dec 17 '12 at 23:21
    
There you go. Thanks for accepting it. –  bassplayer7 Dec 18 '12 at 14:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.