Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I connect my iPod or iPhone to iTunes on a MacBook Pro, it will look like this picture attached. When I right-click on a song to delete it, there is no delete option. What am I doing wrong? This new iTunes has been so confusing.

enter image description here

share|improve this question
    
also if I go to its GetInfo section, everything is read-only –  BDotA Dec 15 '12 at 3:04

2 Answers 2

up vote 3 down vote accepted

This is likely because iTunes is automatically syncing your music.

iTunes sync music

When you automatically sync music, you manage what songs you have on your device by going to the music tab, and selecting which playlists/artists/genres/albums to sync or not sync.

The fix:

To manually manage music, click the Summary tab, scroll to close to the bottom, and in the Options area, there will be an option to Manually manage music and videos. Select this option, and you should be able to delete songs and such from the "On this iPhone" tab.

enter image description here

share|improve this answer
    
I hadn't selected Sync music option but somehow the other thing to Manually Manage Music, that one worked. Thanks. –  BDotA Dec 15 '12 at 17:31
    
Actually, thanks for the feedback. I'll edit my post to make the Manually Manage music a little clearer for future visitors. –  bassplayer7 Dec 15 '12 at 17:41
    
Thank you very much for the clue about manual manage. It was driving me insane! –  user43622 Feb 24 '13 at 2:47

This is on a different computer to mine. I knew to enable "manually manage" etc. however itunes wants to sync to the library on the new computer erasing all my music before I can apply the manaul management of my iphone library. Really annoying not to mention I don't want the phone backing up all the time, sync maybe but not backup too. Also the change of layout was confusing. why did it have to change the old way worked.

share|improve this answer

protected by Community Mar 5 '13 at 14:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.