Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got this AT&T iphone 5 purchased overseas for 800 dollars plus tax.

As soon as I got it, I tried to restore it to bypass the activation screen required by at&t. But restoring didn't go smooth as planned. Now the phone is stuck in recovery mode. And every time I place it in dfu mode, then restore with itunes I get an error 21, if not in dfu mode 1603,1604, 1611 errors come out.

When restoring using dfu mode, what I notice is that, Itunes has the loading labeled preparing to restore iphone. The device on the other hand turns off, and comes up with the apple logo and the daisy/spinning wheel, the wheel spins for about a quarter only and get stuck, and soon after reboots and goes back to apple logo, after that is the popular itunes and usb logo.Then, itunes gives an "Iphone cannot be restored. An Unknown error occurred(21)" something error. The process repeats every time i try to restore in DFU mode.

I've tried almost everything online, relating to this issue, device off and hold home button while connecting the lightning connector and wait for the itunes logo and usb to show up before releasing home button, for example. Done it for countless times, in 4 different computers.

System specs of the computers i've tried it on, 2 pcs with windows 7 64bit, 1 mac book pro, 1 unit windows xp. The ipsw file i'm using is the 6.0.1 for GSM which is appropriate for my gsm device.

Been stuck for almost a week now, will be really sad if this is a hardware failure, it would mean additional expense for warranty.

Any other suggestions i should try? or better yet a fix? i really want to start using this device.

share|improve this question
add comment

3 Answers

I'm not really sure if we are in the same boat. I had been stuck in DFU mode after restoring my iPad to iOS 6.1 without activating it. I have tried using iTunes in restoring the firmware but it was stuck on the iTunes and usb logo just like you. What I did was to use redsn0w to restore my iPad. You can use it without jailbreaking your phone. Hope this helps.

share|improve this answer
add comment

I can't help you myself, but I found you a link for all of your errors.

I can't post more than one or two links, but all the errors you listed have been gathered to a single page right here. You can put #error followed by your error number at the end of the link to jump to an error.

Hope this helps.

share|improve this answer
add comment

I've got "IPad could not be restored Unknown error (21)" after upgrade to new version failed. The following steps from https://discussions.apple.com/message/18064040#18064040 allowed me to reset an IPad, and then I've restored it from ICloud backup.

Power off the iPad completely (wait for the progress spinner to disappear). Hold the Sleep/Wake switch AND the Home button down for a full 10 seconds. After 10 seconds (the second time you'll see the Apple logo on the screen) release the Sleep/Wake switch while still holding the Home button.

share|improve this answer
add comment

protected by Community Apr 26 '13 at 16:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.