Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Despite un-checking the "Reopen windows when logging back in" checkbox when turning off the computer, applications reopen sometimes at the next start-up. Furthermore, this happens also when I quit all the applications manualy before, which is strange. This issue occurs in Mountain Lion (10.8, 10.8.1 and 10.8.2), never actually happend to me in Lion. Maybe it's worth noting that this is not a clean install, but an upgrade from Lion.

Is there any solution how to prevent this (maybe from the Terminal)?

share|improve this question
Which apps are doing this? Is it the same apps each time? – bneely Dec 13 '12 at 22:33
Usually it is most (or all) of the apps I had running (and eventually manually quit) a moment before I turned off the computer. – mouser Dec 13 '12 at 23:44
I have this same issue and have yet to find an answer. It almost seems that I need to quit the apps and wait a couple minutes and then shutdown. If I shutdown too fast after quitting the apps they then will reopen on next startup. I would love to find an answer to this as well. – user55077 Aug 14 '13 at 11:10

Here are a few places to check:

  • "Under the hood" locations:

    • Be careful when working with the plist files in the folders listed below. Some of them may be full programs, others may be "helper apps".
    • Don't touch any plist files for programs you use that may have "behind-the-scenes" assets.
    • If the plist filename is ambiguous, you can look inside the plist files for the name of the application. If there are remnants from old programs you have uninstalled or were before upgrade, move the file(s) in question to your desktop one folder at a time (/Library/StartupItems), then reboot.
    • If your system works as expected (meaning nothing catastrophic happens and the program you were trying to kill is gone), throw the plist files on your desktop away, then proceed to the next folder and repeat the process.
    • When working with files in the Library folders, you may need to authenticate deletes as an administrator.

    • /Library/StartupItems

    • ~/Library/StartupItems (if it exists)
    • /Library/LaunchDaemons
    • /Library/LaunchAgents
    • ~/Library/LaunchAgents (if it exists)
  • System Preferences: Take a look at Users & Groups in your System Preferences and click on the Login Items button at the top of the window. Check if any programs that automatically load after reboot are on the list and set to run at login.

While there may be other ways to clean house, including formatting your hard dive and a fresh install of Mountain Lion (Check out Lion Diskmaker for a thumb drive installer for 10.8), these will give you a good start.

Happy cleaning!

share|improve this answer
I walked through the steps above, just to make sure I was referencing the proper procedures. I found old BlackBerry helper program plist files that were at least four years (and three cell phones!) old. – TomUnderhill Dec 14 '12 at 0:57
Thanks for an exhaustive answer and I sort-of already tried this some time ago, but it didn't seem to help. Problem is that the issue happens like once in 2 or 3 months and it's always just the applications I had open just before I turned off my computer. I already tried many crazy things like always checking and unchecking the checkbox when turning off the computer,but after 3 months of doing it it happend again just yesterday. – mouser Dec 14 '12 at 8:45
so " ~ " means/refers to the System folder, huh? having the same problem, not sure I want to upgrade the whole OS, here, and I managed to figure that out – user107422 Jan 5 '15 at 16:05
it's shorthand for [macHD]/Users/[yourname]/ – Tetsujin Jan 5 '15 at 16:13

Go to apple - shutdown and untick the box that says "reopen windows when logging back in".

share|improve this answer
OP has already mentioned that they have done this. – grgarside Feb 5 '14 at 16:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.