Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My system is working fine (iMac running Mountain Lion), except that when I try to import video to iMovie using the built-in iSight camera I see a message "no camera connected". iSight works fine in Skype, photobooth, etc.

The solution to this, documented here, is to trash com.apple.mio.VDCAssistant.plist at the path /System/Library/LaunchDaemons/ and it's supposed to rebuild after a restart. But when I navigate to this path, the relevant file is just not there. Restart doesn't affect it, neither does logging in with a different user account. Repairing disk permissions doesn't help. I found a file named com.apple.cmio.VDCAssistant.plist at that location but only in a Time Machine backup - it's not present on my current system.

My main question is: does the absence of com.apple.mio.VDCAssistant.plist indicate a deeper problem that ought to be fixed? If not, I can live with not being able to import video directly to iMovie directly from the camera.

If it does indicate a deeper problem, I guess it's time to reinstall the OS. If that's the case, can I restore the system from a time machine backup or will this just reintroduce the original problem?

Thanks for reading - I'd really appreciate any input.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Update: Reinstalled the OS and the 'cmio' file is now there, though doesn't rebuild when moved. iSight still not recognised. The iSight issue must be a bug confined to older versions of iMovie, even though they're still supported by Mountain Lion. I'll use QuickTime to import the footage.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.