Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have tried to re-index my external drive by removing it from Spotlight's privacy settings and putting it back there. I tried with mdutil in the terminal and I've got the following log:

bb:~ bb$ mdutil -i on -d /Volumes/TOSHIBA\ EXT
    Indexing and searching disabled.
bb:~ bb$ mdutil -i on /Volumes/TOSHIBA\ EXT
    Indexing enabled. 
bb:~ bb$ 

I tried it with the root password and when I look for files on my external drive I still cannot find them through spotlight even though I know they are on the drive and I can find them by browsing folders.

Is there another way to index my drive?

share|improve this question
Have you tried dragging the drive to the privacy pane in System Preferences>Spotlight and them removing it from there (as explained in Are you using Apple's NTFS driver (which only allows for read-only mounting) or something like NTFS-3G or Tuxera? – jaume Dec 21 '12 at 8:47
I tried it more than once. – esmitex Dec 26 '12 at 18:33
What about the NTFS driver? Are you using Apple's, Tuxera's, or a driver from another vendor? – jaume Dec 27 '12 at 7:26
I have another driver I had installed back then when I had Leopard. – esmitex Dec 27 '12 at 7:54
And, using your driver, can you write to the external NTFS drive or only read? – jaume Dec 27 '12 at 8:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.