Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use Mac Mail to work with an IMAP account. Is it possible to subscribe only to a set of folders, e.g., synchronize only the folder "current" and all its subfolders, but not the folder "archive"? I tried right-click on folder > Account Information > Abonnements/Subscriptions but there no folders are listed.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Press command-i (letter i) in, select the account in the popup menu and go to the “Subscription List” tab. From there you should be able to select/deselect shared IMAP mailboxes.

share|improve this answer
Thank you, but as I wrote in my question, no folders are listed there... – strauberry Dec 10 '12 at 13:54
Is this your own account or a shared IMAP folder from somebody elses account? You can only configure folder subscriptions for shared folders in Your own folders will always be synced. – MacLemon Dec 10 '12 at 14:01
Its my own account and no shared folders... so you just gave me the answer that it's not possible ;-) – strauberry Dec 10 '12 at 14:15
strauberry: You correctly interpreted as a no. :-) – MacLemon Dec 10 '12 at 15:01

I had this same issue. I am using Mail version 8.2.

I found this to be a fix for me.

When I create a new account in Mac Mail, it shows the account name under "Inbox."

Under that account name are four folders - Sent, Drafts, Junk, and Trash.

You have to click on one folder at a time to highlight it, then in the top menu, select Mailbox > Use This Mailbox As > and select the correct mailbox (Sent, Drafts, Junk, or Trash).

When I did this, my Sent, Trash, Junk, and Draft folders that were under my email account name, moved under the "Main" Sent, Trash, Junk, and Draft sections. It took a second or two for them to sync to the server and not show a warning sign next to the folder name.

Under Mail > Preferences > Accounts > Advanced, I left the IMAP Path Prefix blank. I did change the Port from 143 to 993, checked the Use SSL box, and set the Authentication to Password. I used these settings because they match what my host provider provided me to use for my Incoming Server settings. I'm not sure this mattered or not.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.