Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having issues with my macbook pro OS X 10.7.5. It used to connect to the wifi router (D-Link N300, DIR=615) no problems. But for the past several weeks, I haven't been able to at all.

What pops up when I select my wifi network from the list:

  • "Failed to join "network" A connection timeout occured".

What happens when I try to enter my password manually:

  • "Connection timeout"

What I've tried to do as solutions:

  • Google
  • Restart router by pressing reset & refresh button
  • Delete System & User (Login) Keychain access
  • Network > Gear symbol by the + and - bottom left of the screen > Set Service Order > Drag Wifi to the top
share|improve this question
1  
Have you updated your OS or any other software recently? Also, can any other devices connect to the router, e.g. iPhone, iPad, or another computer? –  jbharper2 Dec 10 '12 at 9:17
    
are you sure the router is actually working? did you test it with a different device? Because routers do actually break from time to time (mine just did and I had to replace it) –  user1256923 Dec 10 '12 at 10:31
add comment

8 Answers

A common fix for this is to make a new location under the Network pane in System Preferences.

Open System Preferences. Click on Network. In the window that loads after that, near the top, is a drop-down menu labelled "Location:" Click on the drop-down menu and choose "Edit Locations..." In the next window that slides down click the + sign. A new line will appear ready to be given a name. I usually enter the date to help me keep track of when I made the new location, and to help prompt my memory why I did it. Give it a name. When you click ok that new location will load automatically. You may have to delete the extra connections you don't use, such as Bluetooth PAN, or Firewire, just to keep the side pane clean. In that side pane choose Wi-Fi, wait for it to automatically locate and attempt to connect to your wireless network, enter your password (and/or whatever steps you do, if you manually have to enter the wi-fi name if it is hidden, for example), and voila, connected again.

But no one really knows why it lost the connection in the first place. Just a weird bit about OS X.

share|improve this answer
    
I tried all this and a pop up saying "Connection timeout" still happened. Thanks for the advice though. –  Lisa Dec 11 '12 at 17:40
1  
It might be worth checking whether other devices can connect or not. Perhaps the D-Link is actually busted. If other devices can connect let us know. –  Shane Dec 19 '12 at 18:29
add comment

Shane's Answer above is very good but would probably be my 4th step. Prior to that, I would first try turning off and on wifi, followed by power cycling the router (physically disconnect the power, wait 1 min then restore power), and then re-starting the computer. These are all very simple steps but are good things to try before you begin changing settings and re-building connections.

share|improve this answer
add comment

Usually when connection timeout occurs, you can attempt the following common solutions.

  1. Turn off WiFi and turn it back on.

You can try resetting the connection information for your router by "forgetting" the router information:

  1. Go to System Preferences > Network: Wifi -> Advanced.
  2. Remove your Preferred Network.
  3. Rejoin network.

You can try resetting your router:

  1. Unplug your router and plug it back in after 10-20 seconds.

You can't transmit on the same channel as other wifi networks. If there is a conflicting router, it may be taking precedence over your router.

  1. Go to About this Mac -> More Info... -> System Report -> Network: Wi-Fi
  2. If your router is running on the same channel as other networks, try changing that:
  3. Plug in via ethernet or try getting closer to your router...
  4. Connect to your router (IP is located in the connection information in your Network preferences)
  5. Change the Router channel to a channel that's not being used by other networks around you.
  6. Restart your router.

If the above still doesn't work, a corrupt entry in your keychain may be the culprit:

  1. Go to Keychain Access
  2. Find all the entries that match your router.
  3. Highlight all matching entries and delete them.

If the above still doesn't work, try some of the troubleshooting tips from here: Wifi Dropping in OSX Lion - Fixes

If all else fails, upgrade to Mountain Lion. That will solve everything. :)

share|improve this answer
add comment

From my experience, the easiest solution is to MANUALLY join the wifi network. Open the wifi menu and click "Join Other Network...". In pop-up dialog explicitly enter the network name, encryption method and password. That's it. Works every time in these situations.

share|improve this answer
add comment

Been there, done that. I found the source to my problem, but not something that might be a general answer for all with this problem.

After exhausting the other answers here, I just started trying anything. What I discovered was that I have an external HD connected by firewire, and had it running when I rebooted after installing software. With the drive running, no connection. I shut off the drive and it immediately connected. Go figure! It runs fine of I start the drive after startup, but not during. (Mac Mini C2D 2.54, OS X 10.8.3)

Perhaps the wires acted as antenna or otherwise changed the power available to the Wi-Fi chipset, but I'm not seeing these timeouts after changing my connected devices and cables.

share|improve this answer
2  
Solved my problem. Went to preferences, network and eliminated firewire as a protocol and it works fine, now. Hope this helps! –  Stephen Mar 23 '13 at 2:23
add comment

I too had the same problem. Really easy solution. Turn off WiFi on your iPad as it may have chosen the same IP address as your Mac. Then your Mac may well join. Restart your iPad, it will choose a different IP.

share|improve this answer
add comment

Going into keychain and deleting the entry for the wifi network solved it. Just connected to the network again and entered my credentials.

There was something wrong with either the password (I doubt this) or the authentication mechanism that was somehow paired with the keychain entry.

Anyway, this also means that going the manual way, as suggested by drovnik will also work, though I have not tried it.

share|improve this answer
add comment

My problem was the Keychain Access, I cleared the Belkin chains from the System and it fixed it instantly. I was racking my brain.

share|improve this answer
    
Hmm - entering the wrong passwords in a network might cause a timeout if the noise were high or there were other overloads - good thing to check and not intuitive from the error message provided. –  bmike Sep 11 '13 at 19:12
add comment

protected by Community Jul 28 '13 at 14:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.