Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I send messages from my iPhone (A) to another iPhone (B), the responses from B keep coming to my Mac and do not appear on my phone (A), even when I have iMessages closed. This is maddening. How can I prevent this from happening?

share|improve this question

2 Answers 2

The best thing to do is just reset your setting and sign out of iCloud on your computer. once it's done reseting on your phone, sign back in on your Mac and every thing should be fine.

share|improve this answer

You have a couple of ways to configure this. First off, make sure both the computer and iPhone have been set up to use the same Apple ID.

  1. You can disable Messages.app's ability to receive text messages on your Mac:

    • Open the Messages application. Access your preferences by going to the menubar and clicking Messages -> Preferences...
    • Under the "Accounts" tab, you will see all the accounts you've set up to use with Messages, including iCloud. Selecting "iCloud" from the options on the left side of that screen will show the email addresses you specified and your phone number.
    • Unchecking these will disable the ability of Messages.app to receive those messages you wish to send only between mobile devices.
  2. On your iPhone:

    • Tap "Settings", then scroll down to "Messages" and tap it.
    • Scroll down to "Send and Receive" and tap it. Look for the menu option heading that says "You can be reached by iMessage at:", which has your phone number (checked by default) and the email account you configured when you initially set up your iPhone. This is probably your apple ID, but can be any other email address you've specified.
    • Simply tap the email addresses that are checked to disable them. This should force messages to communicate with only your phone number.

It should work by disabling all but your phone number on iMessage, but you may need to disable everything on your Mac as well. A little experimentation and tweaking should get you set in just a couple of minutes.

Good luck!

share|improve this answer
    
I tried this and it caused other problems. When another iPhone tried to send me a text message via iMessage my phone wouldn't receive anything at all, so I disabled iMessage completely on my phone, falling back to SMS. –  Darren Newton Dec 9 '12 at 15:07
    
So, the options above represent the sum of the ways in which Messages can be configured on both the Mac and iPhone. Again, you may have to experiment to find the right combination. Can you outline, specifically, what you tried? –  soxman Dec 10 '12 at 6:32
    
Also, I forgot to mention that both devices must be configured using the same Apple ID. Are they configured as such? –  soxman Dec 10 '12 at 6:38
    
I have disabled my Apple ID in iMessage on all of my macs, and also disabled iMessage on my iPhone, forcing it to only response to SMS messages. At the end of the day, this is the behavior that I want for now. The ideal situation is that all iMessages go to every device, which it currently does not do. –  Darren Newton Dec 10 '12 at 13:32
1  
So then what you really wanted, ultimately, was to have messages sync completely and not just to one device. If this is the case, please make sure to update your question in case others have similar problems. The way it's presently worded reflects your frustration, but also directly indicates that you do not wish to have messages sync to your mac, only your iPhone. Also, I am still curious: you have disabled your Apple ID, but is it the same Apple ID? –  soxman Dec 10 '12 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.