Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Lately I've been witnessing this weird visual glitch on the screen of my MacBook (non-retina 2012, hi-res screen):

glitch

I have had to take a picture of it because whenever I try to take a screenshot it goes away right before the screenshot is taken.

I thought this glitch only happened when I had Adobe Illustrator open, which is when I would see it appear more often, but I've now also caught it in situations where the application was not running (the picture above is one of those cases).

I cannot pinpoint the exact cause of this and I cannot tell whether it's a hardware or a software issue, but I can only say it's not one of those flickering effects that appear for a second and then vanish. This is actually very persistent and will only go away when I switch to another application or in some way move the current window.

Does anybody know what this is and what might cause it?

Here are more pictures:

share|improve this question
    
Looks like a graphics card problem. Do you have AppleCare? –  David Holdeman Dec 8 '12 at 18:44
    
No, I don't. Do I have to get it? My MacBook is still under warranty. –  Gabriele Cirulli Dec 9 '12 at 15:41
    
It's probably software making the hardware crazy... given that your mac is new... a firmware update might fix it. Make sure you have all the updates installed. Try gfxCardStatus and see which card is making it worse. –  unmircea Dec 10 '12 at 22:52
add comment

2 Answers 2

up vote 0 down vote accepted

Well, it looks like you may need a visit to the nearest Apple Store,
but first try downloading SMCFanControl: http://www.macupdate.com/app/mac/23049/smcfancontrol and try turning up the fan speed to cool the overheated graphics card and see if that helps.
Please note that I am not sure whether the fan speed on the MacBook is adjustable, but it's certainly worth a try.

share|improve this answer
    
I've noticed that it still seems to do this even when the temperature isn't that high (around 70 °C) –  Gabriele Cirulli Jan 10 '13 at 23:03
add comment

I've fixed my problem completely.

I was using 2x4gb 1333mhz ram on my late 2008 macbook pro.

Screen blinked only when using the integrated 9400m. Mountain Lion would just kernel panic and crash. Gave up and was using 9600gt all the time.

The problem was the ram, it was NOT faulty but the machine says it needs 1066mhz ram and the out of spec 1333mhz caused the integrated 9400m to overclock itself.

I recently bought new memory and the machine has been rock solid. No more screen blinks as all.

The old memory is just fine running on my hp laptop now.

share|improve this answer
    
So you're saying I'd have to switch out for another ram stick? Are you sure this is the exact same problem I'm experiencing? –  Gabriele Cirulli Jan 10 '13 at 23:02
    
I had a similar issue... my mac states it needs 1066 mhz ram and i installed 1333 mhz. It booted up no problem but the screen would blink every second or so when using the integrated graphics card... in mountain lion it froze. –  unmircea Jan 11 '13 at 8:57
    
Did that happen after you manually changed your ram or did it actually come with a faulty module? –  Gabriele Cirulli Jan 12 '13 at 19:00
    
It did not happen before the module, and the new modules weren't faulty they were just higher speed and the machine accepted them but graphics errors occurred. –  unmircea Jan 14 '13 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.