Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I like the fact that sync downloads voice memos to my Macbook Pro. But I do not like the fact iTunes includes my voice memos in my general music library. It's a bit goofy to be listening to my music on shuffle and all of a sudden have it start playing my voice speaking! Is there a way to prevent them from showing up there - but still have them synced?

enter image description here

This has been happening for as long as I've been making voice memos, and is happening in iTunes 11 also.

share|improve this question
    
Setup a smart playlist that includes everything except your memos? Then shuffle the playlist? – Zoredache Dec 7 '12 at 19:37
    
@Zoredache - thanks, I suppose that would work but it seems like Apple should have thought of this issue and done something about it. – jlarson Dec 7 '12 at 20:31
up vote 2 down vote accepted

I totally agree with you about Apple not implementing a proper place for voice memos in iTunes. They've even added a separate window for home made movies in iTunes 11's Movies section. This kind of disappointing.

But anyway, perhaps you already now this but one possible solution would be to uncheck syncing of voice memos in iTunes's settings for your iOS device.

Music settings in iTunes

This way, they won't be downloaded to your MBP so you will have to manually transfer them.

Manual transferring of voice memos might be disappointing for you but on the other hand, a smart playlist might affect your iTunes library's performance since a smart playlist keep scanning library for changes.

share|improve this answer

I HATE Apple sometimes! They do this minimalistic structure on softwares but, in order to do so, they lose track on the real stuff needed to keep the software content really organized.

So, about your answer: you can right click the voice memos, select "get info", go to the tab "options" and select "skip when shuffling" to avoid having it played on shuffle, as someone already said.

But, if your deal is about the aesthetics on iTunes, having an artist on the side tab called "voice memos", "iphone" or "ipod" under your music, what you can really do is selecting everything undesired on this tabs, such as "voice memos", side click over them, select "get info", and them going under the tab "options". After that, the first option is called "media kind" and, instead of "voice memos" - which are displayed on your itunes library, you select "podcasts" which are not.

Hope I helped! It worked for me. But you just have to remember that all this media will be available on podcasts only. Cheers!

share|improve this answer

I agree also that this is an inconvenience, and it is annoying. Some other ways you can resolve the issue is by highlighting all of you voice memos in the entire library (easy to do if you have your library sorted by genre), right click to 'get info', go to the options tabs and check the option 'skip when shuffling' and everything that is highlighted can be still checked and they will never play unless you manually select them.

Also under that same options tab, there's a drop-down under 'Media kind' and if you select 'audio book' instead of voice memo (or music), they will no longer appear in your main library, and will instead appear under the audio books library. Hope this helps.

share|improve this answer
1  
This isn't bad but I'd like an option that requires no manual action after every sync. – jlarson Dec 17 '12 at 19:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.