Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My system is Lion 10.7.x

My Internet Sharing is greyed out with:

Internet Sharing: Off

You cannot start Internet Sharing because you have not selected a port to share your connection.

How can I enable internet sharing?

The internet sharing panel is totally disabled, I can see the drop down but unable to select, I'm using a customized version from corp, they may disabled this function, since I have root permission, I might be able to restore it, do you know where to enable the panel?

I just find my screen shot is exactly the same as this question, not sure if its exactly the same case. Internet Sharing on Mac via LAN

I tried to add a com.apple.nat.plist to /Library/Preferences/SystemConfiguration and tried sudo /usr/libexec/InternetSharing -dDV, I got below in my /var/log/system.log There seems to be no error, but still unable to get it work.

Dec 10 04:24:37  com.apple.InternetSharing[3406]: port forwarding is allowed
Dec 10 04:24:37  com.apple.InternetSharing[3406]: published changes: success
Dec 10 04:24:38  com.apple.InternetSharing[3406]: store_changedDec 10 04:24:38  com.apple.InternetSharing[3406]: set state: silent, state RESET(1020)->ON(1023), reason NO_ERROR(0), errnum 45
Dec 10 04:24:38  com.apple.InternetSharing[3406]: prefs_changed
Dec 10 04:24:38  com.apple.InternetSharing[3406]: published changes: success
share|improve this question
    
That 10.7.12.2.18 is not a version number - they look like 10.7.x (where currently x in range 1-5 –  Mark Dec 7 '12 at 11:54
    
Can you take a screenshot and post it for us? Hit shift-command-4, then space, and click on the Internet Sharing window. The screenshot will be saved to your desktop. –  robmathers Dec 7 '12 at 18:17
    
Thanks, but I failed to post an image because my reputation is lower than 20..., if you could vote my question I may be earn reputation faster. –  Rick Li Dec 10 '12 at 2:46
    
You can upload the screenshot to any sharing site and post a link either by editing the question or adding a comment. –  patrix Dec 10 '12 at 9:48
    
And did you already try the steps from the answer? You must select a network in the "To computers using" part before you can enable sharing in the left panel. Kind of counter-intiutive. –  patrix Dec 10 '12 at 9:52
add comment

2 Answers 2

Thanks all for taking time to look at this, I finally find out the system image is with MCX which disabled the Internet shading

I removed the MCX services and it started to work.

share|improve this answer
add comment

You need to select which networking the connection is to e share on. This is selecting at least one from the list in the bottom right hand of the preference pane.

e.g. to share your ethernet connection over wifi and firewore example share

share|improve this answer
    
The internet sharing panel is totally disabled, i can see the dropdown but unable to select, i'm using a customized version from corp, they may disabled this function, since i have root permission, i might be able to reatore it, do you know where to enable the panel? thanks. –  Rick Li Dec 7 '12 at 17:09
    
Is the padlock symbol open? –  Mark Dec 7 '12 at 19:25
    
Yes, the padlock is open. –  Rick Li Dec 10 '12 at 2:42
1  
So you are saying that you are using a Mac provided (and administered) by your company who for whatever reason choose to prevent you from using Internet Sharing? This piece of information is rather crucial, can you please add it to the question? –  patrix Dec 10 '12 at 11:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.