Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I misspell "maintenance" all the time. I usually ignore the autocorrect suggestion and just send it. Recently my iPhone (and iPad and MacBook - thanks iCloud) have started suggesting the misspelling of this word as a correction.

It's one thing for me to ignore an error, but it's another for it to suggest the error as a correction later on. How do I change this behavior? I don't want to turn off autocorrect, I just want to remove this misspelling from the autocorrect suggestions. It also doesn't appear in "shortcuts" in keyboard settings, since it was never defined as a shortcut.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

When you type something several times and ignore the suggestion, iOS assumes you mean to type it that way and adds the word to the Keyboard Dictionary. You can reset the dictionary by going to Settings > General > Reset and tapping "Reset Keyboard Dictionary". You cannot reset the dictionary in a granular way.

A possible workaround, however, if you don't want to reset the whole dictionary, is to add the misspelling as a shortcut and set the replacement phrase as the word spelled correctly. To do this go to Settings > General > Keyboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.