Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Running 10.7.5, I've got a fairly new iMac (6 months old) 27", set to never sleep, yet when I got in to work this morning it was asleep. How to fix this?

Output from pmset -g in Terminal:

Active Profiles:
AC Power        -1*
Currently in use:
 autorestart    0
 powerbutton    0
 halfdim    1
 panicrestart   157680000
 hibernatefile  /var/vm/sleepimage
 networkoversleep   0
 disksleep  0
 sleep      0 (imposed by 139)
 hibernatemode  0
 ttyskeepawake  1
 displaysleep   15
 womp       1

And the contents of the com.apple.PowerManagement.plist in /Library/Preferences/SystemConfiguration:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ActivePowerProfiles</key>
    <dict>
        <key>AC Power</key>
        <integer>-1</integer>
    </dict>
    <key>Custom Profile</key>
    <dict>
        <key>AC Power</key>
        <dict>
            <key>Automatic Restart On Power Loss</key>
            <integer>0</integer>
            <key>Disk Sleep Timer</key>
            <integer>0</integer>
            <key>Display Sleep Timer</key>
            <integer>15</integer>
            <key>Display Sleep Uses Dim</key>
            <integer>1</integer>
            <key>Hibernate File</key>
            <string>/var/vm/sleepimage</string>
            <key>Hibernate Mode</key>
            <integer>0</integer>
            <key>PrioritizeNetworkReachabilityOverSleep</key>
            <integer>0</integer>
            <key>RestartAfterKernelPanic</key>
            <integer>157680000</integer>
            <key>Sleep On Power Button</key>
            <false/>
            <key>System Sleep Timer</key>
            <integer>0</integer>
            <key>TTYSPreventSleep</key>
            <integer>1</integer>
            <key>Wake On LAN</key>
            <integer>1</integer>
        </dict>
    </dict>
    <key>LastSleepUUID</key>
    <dict>
        <key>Date</key>
        <date>2012-12-06T04:39:59Z</date>
        <key>UUID</key>
        <string>019EBED9-FE31-4B63-8D7A-99F41B6EB618</string>
    </dict>
</dict>
</plist>

As you can see, it has record of going to sleep this morning at 4:39 AM, yet all settings also show it's set to NOT go to sleep. Any ideas what's going on?

share|improve this question
add comment

1 Answer 1

Do you perhaps have a schedule set to sleep the system? System Prefs > Energy Saver > Schedule button, or pmset -g sched (just sched).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.