Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I’m unable to use Autofill to add songs in iTunes 11 and I’d really like to use it.

Following the help guide in iTunes, it says I should be able to see an “Autofill from” pop-up menu at the bottom of the music pane:

Unfortunately, this is what I see instead:

Attempting to set my iPhone to have music be manually added also seems like a no-go:

Any ideas how I could see that Autofill pop-up menu?

share|improve this question

4 Answers 4

I think they mean on the tool bar on the upper right, with your device connected and the view you are showing is the devices pane. Look in the upper right and there should be a blue done button click the blue button. and it will take you back to the itunes music page. With your device plugged in it will be where the auto fill should be. I don't keep music on my iPad, when it got done syncing I disconnected my iPad and autofill did not show back up. don't know if it is because I don't keep music on the device or not, but it was there before I synced.

share|improve this answer
  • Select your device.
  • Click the Summary tab.
  • Under the Options section, make sure that "Manually manage music and videos" is checked:

enter image description here

  • If the Sidebar is visible, expand the disclosure arrow for your device in the devices list and select Music:

enter image description here

  • If the Sidebar is hidden, select the On This iPad (or iPhone) tab and select Music:

enter image description here

  • The Autofill functionality should now appear:

enter image description here

share|improve this answer
    
Bryan: I’ve updated my original post with a screenshot of what my Options screen looks like – I can’t seem to be able to set “Manually manage my music and videos”. Do you know what would cause this? –  Edward Ocampo-Gooding Dec 6 '12 at 21:32
    
Edward: I'm not sure what would cause that. What happens when you check it? Have you tried clicking "Apply" after checking "Manually manage music and videos"? –  Bryan Luby Dec 6 '12 at 22:28
up vote 3 down vote accepted

I figured it out with some help from Jesse at the Ottawa Apple Store:

If your iPhone has iTunes Match turned on, you’re not able to manually manage your music. In order to set how much space you want to use on your device for music, you’ve got to first turn iTunes Match off, set your space requirements in the Autofill section, and then turn iTunes Match back on.

Good times…

share|improve this answer

I figured it out, all you have to go is go to your iPhone and go to the tab "on this iPhone" then you can autofill at the bottom!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.