Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my keyboard layout, the M key is right next to the W key:

Dvorak keyboard with adjacent m and w keys circled

This can be problematic at times because occasionally I will accidentally press Command-M instead of Command-W, causing the window to be minimized rather than closed.

Since there's no keyboard shortcut to un-minimize a window (well ok, no easy keyboard shortcut), this is even more annoying because then I have to switch to my trackpad to un-minimize the window and then try again to close it.

Is there a way to disable the Command-M shortcut for minimizing a window?

share|improve this question

5 Answers 5

up vote 12 down vote accepted

You can disable it by editing ~/Library/Preferences/.GlobalPreferences.plist:

defaults write -g NSUserKeyEquivalents -dict-add 'Minimize' '\0'

To apply the changes you have to reopen applications. If the shortcut was assigned to nil, pressing L would trigger it in Audacity.

share|improve this answer

You can "override" the default Command-M shortcut by mapping it to something else. To remap the key combination, launch System Preferences and choose Keyboard. Then the Keyboard Preferences Panel appears, click on the right tab named "Keyboard Shortcuts". You will notice many default keyboard shortcuts that you can override.

I've tried remapping Command-M using this method and it works.

share|improve this answer

Remapping Command-M to Zoom in "All Applications" seemed to be a good workaround as Zoom appears in all applications and doesn't have nearly as disruptive an effect as an unintentional Minimize.

I was going to try the terminal command above so I went to remove the command M for Zoom and lo and behold, Minimize was now listed with no key command. So I just left it that way, now command-M does nothing and minimize lives harmlessly in the Menu. No terminal command necessary.

share|improve this answer

You can remap any key and key combination with the wonderful and free software Karabiner: https://pqrs.org/osx/karabiner/

After installing Karabiner, just add the following code to your ~/Library/Application Support/Karabiner/private.xml:

  <item>
    <name>Map Cmd-M to Cmd-Alt-M</name>
    <appendix>Changes the minimize shortcut</appendix>
    <not>EMACS</not>
    <identifier>private.kill_m</identifier>
    <autogen>__KeyToKey__ KeyCode::M, ModifierFlag::COMMAND_L|ModifierFlag::OPTION_L, KeyCode::M, ModifierFlag::COMMAND_L</autogen>
    <autogen>__KeyToKey__ KeyCode::M, ModifierFlag::COMMAND_L, KeyCode::VK_NONE</autogen>
  </item>

  <item>
    <name>Map Cmd-Q to Cmd-Alt-Q</name>
    <appendix>Changes the quit shortcut</appendix>
    <not>EMACS</not>
    <identifier>private.kill_q</identifier>
    <autogen>__KeyToKey__ KeyCode::Q, ModifierFlag::COMMAND_L|ModifierFlag::OPTION_L, KeyCode::Q, ModifierFlag::COMMAND_L</autogen>
    <autogen>__KeyToKey__ KeyCode::Q, ModifierFlag::COMMAND_L, KeyCode::VK_NONE</autogen>
  </item>

Then klick "Reload XML" in the Karabiner preferences and set checkmarks for the new items.

This way the minimizing shortcut is not entirely disabled but still available with the additional option key: Cmd+Option+M or by simply using the right command key: Cmd (right)+M.

Note that the second part also changes the Cmd+Q shortcut to Cmd+Option+Q for your convenience. You can omit the second item, if you don’t need it.

share|improve this answer

There's a handy keyboard layout called "Dvorak - Qwerty⌘". It's basically Dvorak, but it flips the layout to QWERTY while the ⌘ key is held down. It was designed so that people who want to learn Dvorak don't have to retrain their hotkey muscle memory, but it could help you too.

share|improve this answer
    
Too late; I've completely forgotten QWERTY by this point ;) –  user5118 Nov 30 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.