Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've set up a few email aliases in iCloud under pseudonyms.

If I receive an email to one of them (e.g. "Alias Name <pseudonym@icloud.com>), and I try to reply in Mail for Mac, it uses the right email address, but instead of putting "Alias Name" in the from field, it appends my real, full name:

Full Name <pseudonym@icloud.com>

No doubt that's very frustrating and unreliable.

In the drop-down, I can select Alias Name <pseudonym@icloud.com> but that's a hassle each time — I have already forgotten and compromised my pseudonym a few times.

What do you suggest? Is this a bug with my setup, or for everyone?

share|improve this question
    
This is happening in OS X Lion for me, can anyone else replicate? –  Baumr Dec 11 '12 at 1:11
1  
Does it show up in the reciever's end as well? Search for the address in your address book and remove it from any contacts and see if that helps. –  Emil Feb 7 '13 at 18:04
    
@Emil yes it does :| and thanks, tried that with no luck — does it happen for you as well? –  Baumr Feb 8 '13 at 22:10
1  
How did you set up your alias/synonym address? I'll see if I can replicate it. –  Emil Feb 8 '13 at 22:11
    
@emil thanks; just through iCloud.com the standard way — but names on both are different –  Baumr Feb 8 '13 at 22:12
add comment

1 Answer

I am unable to replicate this behaviour – when I click "Reply" in the native OS X Mail app, having All Inboxes selected, the address and correct alias name pops up. (If I only have the iCloud-inbox selected, it automatically replies from the main iCloud address..)

One thing you should do is double check the alias' settings on iCloud.com – specifically the alias name. If it's filled correctly, try to remove the iCloud (mail)account from your mac and relink it. If that doesn't fix it, go all the way and remove the actual alias from iCloud and make a new one, and try again. If even that doesn't fix it, throw your mac on the ground and walk away angrily. (No, don't actually try that, it won't work)

If nothing works, and you are unable to replicate this behaviour on a different computer, delete all settings and completely reset the Mail app.

share|improve this answer
    
I will try and report back — what OS do you have? –  Baumr Feb 11 '13 at 16:57
    
10.8.1 (Mountain Lion). –  Emil Feb 11 '13 at 19:21
    
Ah, I have Lion, maybe it's that — but will look into it –  Baumr Feb 11 '13 at 23:19
    
It could be, seems like an odd bug though. –  Emil Feb 12 '13 at 7:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.