Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Starting with GIMP 2.8, the application is no longer visibly dependent on X11, so suddenly all the advice I'm aware of for adding fonts to GIMP don't seem to work.

(This worked with GIMP 2.6)

Now what's a reasonable way to get GIMP to accept new fonts? Preferably I'd like it to use all the same fonts I've got installed in the system Font Book.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You can add fonts from the preference menu item: Gimp-2.8 -> Preferences -> Folders ->Fonts. Now simply add the folder containing your fonts.

/Library/Fonts/ for systemwide fonts ~/Library/Fonts/ for user installed fonts

share|improve this answer

This doesn't meet my desired set up of working with Font Book, but it does work:

  1. Create a directory ~/.fonts/
  2. Copy fonts into that folder.
  3. Press the refresh button at the bottom of the font picker.

Note, I found the idea for ~/.fonts/ by nosing around in /Applications/GIMP.app/Contents/Resources/etc/fonts/fonts.conf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.