Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Lion on Macbook2,1 and after I've upgraded from Leopard, I've noticed that some folders including Pictures are shown empty in Finder. Size of folder says otherwise and in Terminal I can see all my files and folders.

Any Idea what's going on?


Iffat:Pictures mac$ cd Photo\ Booth\ Archive/
Iffat:Photo Booth Archive mac$ ls -l
total 0
drwxr-xr-x   94 mac  staff  3196 Nov 22 15:26 Archive up to 91.08.13
drwxr-xr-x    3 mac  staff   102 Nov 22 15:26 Family
drwxr-xr-x   31 mac  staff  1054 Nov  2  2011 First Soheil Setup
drwxr-xr-x   11 mac  staff   374 Nov  2  2011 Mita
drwxr-xr-x    3 mac  staff   102 Nov 22 15:26 Tidy

In Finder's Get Info, there isn't much to tell, everything is normal, except for Kind: Folder which is missing.

Size: 338683879 bytes (339.3 MB on disk) for 278 items
share|improve this question
Can you add the Terminal directory listing to your question, as well as the Finder Info window for the folder? – robmathers Dec 4 '12 at 16:43
where ever Kind: Folder is missing, it does not show the contents. – Bizz Dec 4 '12 at 17:08
up vote 4 down vote accepted

Can't say I've ever seen that sort of behaviour before, I'm not really sure what might have caused it, but I've got two things to test.

First off, it's possible that the folders got hidden for some reason. Try running

chflags -R nohidden ~/Pictures/Photo\ Booth\ Archive/*

If that doesn't work, see if you can access the folders directly in the Finder by focusing the Finder, pressing ⌘ cmd + ⇧ shift + G and entering the full path of one of the folders into the "Go to the folder:" dialog. If Finder can get there, then there's likely some setting hiding them from view; if not, then there's some reason Finder can't properly access the actual directories on disk.

share|improve this answer
Thank you. chflags -R nohidden ~/* did the trick. – Bizz Dec 5 '12 at 6:08
Great, glad it worked. Strange that it would happen in the first place, perhaps because it's associated with Photo Booth… – robmathers Dec 5 '12 at 6:12
Could it be a virus? cause I don't have antivirus on my mac. – Bizz Dec 5 '12 at 6:16
No, that's fairly unlikely. It's probably a bug in the Lion installer — I recall in one of the previous versions Photo Booth changed how it stores its pictures, so part of the installer related to that may have modified something it shouldn't have. – robmathers Dec 5 '12 at 6:19
chflags -R nohidden worked for me – s g May 20 '15 at 20:25

I did chflags -R nohidden name_of my directory and it did not work. Then I clicked on the apple icon on the top left left, went to "Force to quit", selected Finder, confirm clicking on the "relaunch" icon and it works.

share|improve this answer

I have the same problem - in finder folders that had files in them earlier show as empty later on. I find that a reboot always corrects the finder views, until something causes them to disappear again several hours or even days later. If I force quit finder and relaunch then finder never relaunches so the reboot is the only option.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.