Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On an iPhone running iOS 6.0.1, I used Settings → Notifications → Mail to set different "new message" sounds for different mail accounts. Now I want to make all mail accounts again follow the default sound set under Settings → Sounds → New Mail. How can I do this? When I change the "New Mail" alert sound, the individual mail accounts no longer change.

I have tried manually setting all the mail accounts to use the same sound and vibration setting as the default. However, they still don't change when I change the default setting.

share|improve this question
    
does the issue still persists after the 6.1 update? –  Macmaniman Jan 31 '13 at 15:59
    
@Macmaniman Yes. There's no UI element I can find that would "follow default settings", so as far as I can tell each mail account is "follow the default settings until I customize it once, then never again". –  Stephen Jennings Feb 11 '13 at 21:39
    
For some dumb reason i cant figure out how to comment so please someone tell me, considering your problem still persists, i recommend, iCloud backup/restore. however, the problem might persist, sense its a "setting" its worth a try! –  Macmaniman Feb 13 '13 at 13:58
    
@Macmaniman It's not worth it to me to go through that much trouble. An easier solution would probably be to delete then re-add the mail account. But, I also don't want to bother with that. It's just odd that there doesn't seem to be a setting for this. –  Stephen Jennings Feb 14 '13 at 7:38
    
it is, you are right, but, its really not touble, i think its suuuper easy, however, you are absolutly right its wierd that you cant reset the setting! –  Macmaniman Feb 19 '13 at 23:23

1 Answer 1

It's not a direct answer, but by deleting an App, you remove the local cached copy of the emails and don't lose any messages on the Mail server.

This has a side effect of clearing the preference for sounds, so when you add the account back - it now follows the default sounds as set in the UI.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.