Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying some of the tips from the Cult of Mac iTunes 11 tips blog post. I don't see Options > Assign To > All Desktops when I right click my iTunes 11 icon. Any ideas? Using OSX 10.8.2, that matters.

Here’s a nifty tip for using iTunes 11 in multiple Spaces or monitors: right click the iTunes icon in your dock and select Options > Assign To > All Desktops. Now when you use iTunes in full screen mode, you can also open the MiniPlayer separately and have it run in a different space or monitor. So you could have iTunes running full screen on your big external monitor while the MiniPlayer is on your laptop screen.

Screenshot

share|improve this question
    
On my Lion machine, I still have that option, but there are definitely some bugs in iTunes 11, so perhaps it doesn't show up for some configurations. –  robmathers Dec 3 '12 at 16:41
    
I'm on ML and don't see the option either –  patrix Dec 3 '12 at 17:00
    
for me it is working under ML - do you have spaces activated? –  Pfitz Dec 3 '12 at 17:32
    
Yes, thought of that first. –  Mike Dec 3 '12 at 17:38

1 Answer 1

Killing dock a couple times seemed to fix the problem:

killall Dock

In case Dock doesn't get restarted automatically run

sudo launchctl load System/Library/LaunchAgents/com.apple.Dock.plist
sudo launchctl start com.apple.Dock.agent
share|improve this answer
    
Yep, same here. –  patrix Dec 3 '12 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.