Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I upgraded from OS X 10.6 to OS X 10.8 a few days ago. I find that when I use the keyboard shortcut (⌃ ctrl + ⌥ alt + ⌘ cmd + ⏏ eject) to shutdown, on startup all the previously open applications are reopened automatically. When I shut down from the Apple menu, there is an option "Reopen windows when logging back", but there isn't one when I use the keyboard.

So how can I shut down my Mac Pro using the keyboard shortcut and not reopen windows on login?

I don't wish to disable the feature as described here but I will if I have to.

share|improve this question

4 Answers 4

If you uncheck the checkbox, it should stay unchecked by default in 10.7.5 and later. After that you can shut down by just pressing ⌃⌥⌘⏏.

In 10.8:

  • If "Reopen windows when logging back in" is checked, applications that were open before you logged out are reopened after you log back in, and the state of the applications is restored. It doesn't depend on whether "Close windows when quitting an application" is checked or not.
  • If "Reopen windows when logging back in" is not checked and "Close windows when quitting an application" is not checked, applications that were open before you logged out are not reopened after you log back in, but the state of the applications is still restored if they are opened manually or as login items. If "Close windows when quitting an application" is checked, the state of the applications is not restored when they are opened manually or as login items.

In any case, the state of applications is still restored (or there is an option to restore state) after the Mac was forced to shut down.

The list of applications to reopen at login is stored in ~/Library/Preferences/ByHost/com.apple.loginwindow.*.plist.

share|improve this answer
    
Sorry this didn't help me. In fact I realized that the check box wasn't doing anything anymore. Even when I shutdown or restarted from the menu-bar it would restore the windows. I ended up following the instructions on a youtube (youtube.com/watch?v=maV29fUa4LU). it is working now...although I'm not sure what is really wrong. –  hba Dec 3 '12 at 23:55
1  
It only disables reopening open applications. Their state is still restored if they are opened as login items or manually. See this question. –  ؘؘؘؘ Dec 4 '12 at 15:59

I have the same problem I've restricted permissions to read only for the '~/Library/Saved Application State' folder, it's better but applications still randomly relaunch at the next start. I say randomly because sometimes some do other don't, pretty annoying. Shortcut was working fine with 'restore' option off in 10.7.

Note that the Apple support doc for OS X Mountain Lion: shortcuts for shutting down and sleeping doesn't mention as a way to shutdown your computer but the Apple support doc for OS X keyboard shortcuts still does.

share|improve this answer
    
thanks for the formating daviesgeek. –  mecano Dec 15 '12 at 9:44

Copied from: http://apple.stackexchange.com/posts/98756

This can all be controlled by a Preference. Below is for Mountain Lion, which was changed slightly from Lion:

  1. Apple Menu - System Preferences

  2. General (under Personal section)

  3. Select "Close Windows when quitting an Application" - this makes it so windows don't open when you reopen an app.

  4. Now when you shut down (and tell it not to reopen windows on restart) they will not open then - or later.

share|improve this answer

If you can shortcut to execute a command from the shell (using Terminal.app), you can use

shutdown -h now
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.