Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently bought a new hard drive and it is not indexed by Finder. I tried to get it re-indexed by following this tutorial: http://reviews.cnet.com/8301-13727_7-10330114-263.html and I even tried something with commands in the terminal, no luck to get it indexed.

My previous external hard drives (Western Digital SE Elements) that crashed were indexed, but I was using Leopard and Snow Leopard back then.

I am using a Macbook pro 13" mid-2009 edition and my external drive is a 500Gb Toshiba Stor.E Canvio.

Does it have to do that I uninstalled software I used back then on Leopard to be able to read NTFS drives?

share|improve this question
    
What does diskutil list show for that drive? –  bmike Dec 2 '12 at 17:21
    
This is what it shows: /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *500.1 GB disk1 1: Windows_NTFS TOSHIBA EXT 500.1 GB disk1s1 –  esmitex Dec 2 '12 at 20:24
add comment

2 Answers

Esmitex, kindly try the following steps:

  1. From the Apple () menu, choose System Preferences.
  2. Click Spotlight.
  3. Click the Privacy tab.
  4. Drag a folder or an entire volume (your hard drive) to the list.
  5. If prompted for confirmation, click OK.
  6. Remove the item or volume you just added to the list by clicking it and then clicking the minus ("-") button.
  7. Close Spotlight preferences.
  8. Spotlight will re-index the contents of the folder or volume.

If the steps mentioned above does not work, try downloading this supplemental update for Mountain Lion and repeat the steps above.

http://support.apple.com/kb/DL1600

Hope this helps...

share|improve this answer
add comment

From the Terminal application type the following:

mdutil -s /Volumes/<your_disk_name>/

If indexing is disabled you will get something like that:

/Volumes/<your_disk_name>:
Indexing disabled. 

You can turn it on by typing (it will request your password):

sudo mdutil -i on /Volumes/<your_disk_name>/

Now erase all the existing entries in the index for that drive (if any):

mdutil -E /Volumes/LaCie/

Check that indexing has been enabled:

mdutil -s /Volumes/<your_disk_name>/

If indexing is enabled you will get something like that:

/Volumes/<your_disk_name>:
Indexing enabled. 

Now just reboot your system or wait some minutes until finders begins the indexing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.