Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I added a new album to my iTunes (version 11). It has been copied to my Media folder and it plays fine. But it's not listed in my Albums, Artists and Songs sections. I would like to see the artwork in my Albums or list of songs.

I'm able to find the album by searching. What to do? Any ideas?

I believe that adding it again might help, but how do I remove it from my library when it is not present anywhere except search results?

share|improve this question
    
if you can find the tracks/album by searching for it they must be in your Mediathek maybe it is placed where you don't expect it to be. I'm thinking about Sort Album Artist / Sort Album Name. They some times are different From Album Artist / Album Name. so to verify search for them then rightclick->edit and have a look what the Sorted Album Name is. –  konqui Jul 2 at 5:03

3 Answers 3

  1. Try pressing command+ L while the song is playing, this will take you to the song/album in your library.
  2. Then right click and choose "Get Info" to verify the metadata for the song & album.

It may not be displaying as expected if the metadata for the song doesn't match the filenames.

share|improve this answer

You can try to search in the playlist "Recently Added" for the items you have added. If they appear in there, right click the items and click on the "Options" tab and set "Media Type" to "Music".

share|improve this answer
  1. Find the song in iTunes:

    • In the search tool in iTunes 11, type the song name to find the song. Once it is displayed, you should be able to click once on the result to go to the song.
    • Alternatively, you can press cmd+L while the song is playing as described by @DavidLumpkin.
  2. One the song has been found, right-click on it and choose Get Info.

  3. In the Info tab make sure that the Name, Artist, and Album fields contain the correct information.

    • If there is any text - even a space - in the Album Artist field (highlighted in red), the song will be sorted under the Album Artist, instead of the Artist. To fix this, either leave the Album Artist field blank, or populate it with the same information that is in the Artist field.
    • See screenshot:
      iTunes Info tab
  4. In the Sorting tab, make sure that the Sort Name, Sort Artist, and Sort Album match the Name, Artist, and Album.

    • iTunes will sort the song under the sorting information given in this tab.
    • Again, note that if you have any text in the Album Artist and Sort Album Artist fields, the song will be sorted under the Album Artist, instead of the Artist.
    • See screenshot:
      iTunes Sorting tab

Note that I am not currently on a Mac computer with iTunes installed and have thus taken the two screenshots above from the internet. I do not own the screenshots.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.