Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since iCloud now offers a way for me to download apps directly from the cloud and I only want to keep updating the apps I use on my iOS device and not all that I have, I wanted to keep all my apps only on my iPhone.

So I followed this page, but apparently on iTunes 11 I can't unsync my apps. If I want o sync with iTunes, I need to sync my apps (at least the ones that I have on my device).

The iTunes help pages, though, show a checkbox before Applications, under the Apps menu on my device section on iTunes. Is that a bug then? Or it is just a settings I can enable. I don't want to keep any apps on my Mac, but I don't want also my device to stop synching with it.

Update: I've got a bug report open since 19-Feb-2013 that got some updates from a Apple dev requesting info (which I provided), but still no further comments and fixes. Unfortunately there is not link for it, since bug reports from Apple are private, but the details are above:

Bug ID #: 13051820
Bug Title: Not being able to sync with iTunes without loading apps from iOS
share|improve this question
    
Yeah, that's a real pain… –  F'x Dec 3 '12 at 8:57
    
It is absolutely incredible that Apple removed that switch. iTunes just asked me if I want to transfer all my apps to iTunes (iTunes did not have on single of my apps). If I did not transfer, iTunes would have deleted all apps from my iPhone. –  Martin Dec 3 '12 at 22:55
    
All I could do is manually delete the apps and then sync back. Now I only need to maintain those apps that are on my device. Still, some GB that are totally unnecessary now that we have iCloud. –  lucasarruda Dec 4 '12 at 13:26

3 Answers 3

I am not sure that is what you want but here is what I've done.

I keep my apps sync'ed and let iTunes download everything on my Mac.

However, as I do not want my main HDD to be filled by these apps, I moved them to an external backup drive.

To do this, I go to the 'Apps' section of my 'Bibliothèque' (I have a french version of iTunes, but you can find it in the listbox that is in the upper left corner of iTunes main window).

There, I choose an app, right click and 'display in Finder'.

Here you are in the directory where all apps. You can move them elsewhere or simply delete them. After that iTunes will just warn you it cannot find the app anymore, but at least the deleted apps will not be copied anymore to your Mac.

Of course, you will still have to wait that synchronization copies your newly installed apps to your Mac, but once you've deleted the app on your Mac, it will not be sync'ed anymore.

share|improve this answer
    
that was exactly what I did, if you can see by the comments above. Probably from some kind of index it think it has all those apps, but the files are missing. The problem though persists, since this is kind of a hassle. –  lucasarruda Jan 19 '13 at 12:54
1  
You can post a bugreport at bugreport.apple.com to indicate you disagree with this lack of feature. Perhaps they will indicate you why it was disabled and how do this using another feature. –  lauhub Jan 20 '13 at 20:01
    
Thanks, will do that and post the result (if I get one!). –  lucasarruda Jan 21 '13 at 14:13

The checkbox has finally been found!

In iTunes Preferences, on the Store tab, in the Automatic Downloads section, you will find there is an Apps check box. Change that to off and then click OK. Please be careful, as it seems to need some time to really store the updated preference. Double check by selecting Preferences again.

Plug in the iOS device. It will continue step 7 if you cancelled it in the last sync. Please wait patiently until it is finished. Then, in the next sync when the iOS device is plugged in, step 7 will never appeared again.

For more information:

How to stop syncing apps with iTunes without wiping them from my iPhone?

http://www.pcworld.com/article/2019315/how-to-go-back-to-itunes-10-part-2.html

This is not a solution to get the check box back, but just to revert to itunes 10 (I like it better than iTunes 11).

share|improve this answer
    
I've had all the Automatic Downloads checkboxes off for a very long time and apps are still being transferred from my iPhone to my Mac. –  zigg Oct 17 '13 at 12:04
    
Yeah, unfortunately, that's not a solution to the problem. –  lucasarruda Dec 18 '13 at 13:44

It seems there is no way to stop iTunes 11.4 from syncing apps back to iTunes from my iPhone. BUT... I think at least I found a way to prevent it copying them back to iTunes/my HDD:

Close iTunes. Find out where your 'Mobile Application' folder is located on your HDD. Delete it or put it in the trash at least.

Then open Terminal and change to the folder iTunes Media folder. If you don't know how to do that type 'cd' (without the quotes) plus a space and then drag the parent folder of your 'Mobile Applications' folder (normally the iTunes Media folder) onto the Terminal window. It should paste the location.

Then create a symlink to any location on your HDD, doesn't matter where. Example:

ln -s path/to/target/location Mobile\ Applications

Create a folder called 'Mobile Application' in that target location (although I'm not sure it's even necessary).

Now you have an Alias (sym link) in the iTunes Media folder pointing to a different location.

Since my iTunes somehow can't deal with sym links it will try to sync back the apps from my iPhone but won't copy any of them in effect.

It's not perfect because you still have to wait out the step where it tries to sync back the apps. But at least it won't copy anything and it's faster.

One note: my iTunes Media folder lives on an external drive. I can't really say if iTunes behaves the same if you have yours in the default location in your home folder's music folder. But give it a try.

share|improve this answer
    
For me, simply deleting the apps from the folder made iTunes not sync them back again. Maybe because it thought (through metadata) that they where still there. –  lucasarruda Sep 29 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.