Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In iTunes 10.x, if you searched for items (top right) it would filter the column browser to only show values that matched your search query. Now when I search, it filters the list of items, but not the column browsers. Is this an option somewhere?

share|improve this question

To get the desired effect you can click on the "magnifying glass" icon and deselect "Search Entire Library". This prevents the Miniplayer version of the search and filters both your Column Browser and the list of songs (or artists/albums/genre).

share|improve this answer

Thanks - frntk answers my problem of how to sort or select by composer: Right-click on the magnifying glass and deselect 'Search Entire Library'. But why on earth does this enable searching by composer?

The other way of searching by composer without deselecting 'Search Entire Library': Enter the search query; e.g. 'Bach' A window opens with a magnifying glass and the message 'No Results'. A button invites a search of the iTunes Store. Another message in blue at the top of the window gives Search 'Bach' in Music. Click on this or press Return and the search is done.

But why on earth is it arranged this way? Searches of artist, track title etc don't require the convoluted method above.

share|improve this answer

The search library control in the top right of the main iTunes window now invokes the MiniPlayer version of the search control.

To search in the column browser, you have to select one of the panes (anything in there will do) and start typing. So if you select any Genre and type "blu" you'll get bluegrass or blues or the closest genre to that search string.

share|improve this answer
+1, it's a good workaround. But if I'm doing a search for say "Piano Concerto" in my second column (groupings), 10.x would filter the composer column browser to only show composers who had an item with "Piano Concerto" in the grouping. Any ideas on how to get that to work again? – lukiffer Nov 29 '12 at 22:38
Your classical music case may be a tough nut to crack - the presentation in version 10 seems vastly superior to me based on your other question and screen shot. – bmike Nov 29 '12 at 22:41
Thanks for the thought you've put into it though - I suppose I'll just stick with iTunes 10 until something reveals itself. Pretty much stuck with iTunes though as my Apple devices rely on it and I'm invested in another year of iTunes match. Thanks again. – lukiffer Nov 29 '12 at 22:44

This thread is quite old, however one may benefit from my input. If one was to go to view on the drop-down menu and select view options, from there one must check every box one wants their searches to include. If one was using a newer version of iTunes one must click on the Songs tab to edit this list, e.g. Songs/Albums/Artists/Genres and so on. This may crowd up the list view a bit this is the only way for other fields to be included in searches.

share|improve this answer

big problem with the search on top right : it doesn't search in all the tags! I use the grouping one to write the labels, if I search a label, it just doesn't show up.

edit: my bad, if I display the grouping column, it works. but not sure it was like that in itunes 10.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.