Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

A couple months ago I took a trip out of town, so I set FaceTime on my Mac to auto-answer calls from a specific email address of mine. I followed these directions:

http://osxdaily.com/2011/01/17/automatically-accept-facetime-calls-mac/

It worked like a charm, but now that I'm back I want to disable this ability, and can't! I've tried to use:

defaults delete com.apple.FaceTime AutoAcceptInvitesFrom

And though it reports to have done its job:

There is no (AutoAcceptInvitesFrom) default for the (com.apple.FaceTime) domain. Defaults have not been changed.

Facetime is now actually auto-answering ANY incoming calls. Not even just those from the email address I originally specified.

Obviously this is not a great thing as I'm getting facetime calls out of the blue while in the middle of a conference call with a client, talking to my family members, etc.

How on earth can I truly disable facetime from auto-answering any calls, ever?

UPDATE: April 14 2014. This is still happening in Mavericks when I turn Facetime back on. I would really like to be able to use FT now that there are audio calls, but I can't have it auto-answering all incoming calls all the time.

How on earth can I disable this? I again tried

defaults delete com.apple.FaceTime AutoAcceptInvitesFrom

But got

Domain (com.apple.FaceTime) not found.

in response.

UPDATE 2: It gets weirder. on a lark I decided to try this again too:

defaults write com.apple.FaceTime AutoAcceptInvites -bool false

And this time around, IT WORKED! Sortof. My iMac now no longer auto answers calls. However this same command does absolutely nothing on my MacBook Pro, which is still auto answering every call.

So I'm halfway to a solution... anyone have any idea what's going on with the MBP?

share|improve this question

3 Answers 3

It's a bit of a drastic move, but why not delete the preference files for FaceTime? This should put FaceTime in an uninitialized state (at least for preferences, perhaps not for configured accounts).

Close FaceTime, click on the Finder, then hit the Go menu and choose Go to Folder….

Enter ~/Library/Preferences into the box and press enter. Look for any files that start with "com.apple.facetime" and move them to another folder (for backup purposes).

Open FaceTime back up, check your preferences, and see if the Auto-Accept continues to occur.

share|improve this answer
defaults write com.apple.FaceTime AutoAcceptInvites -bool false

found this here: http://krypted.com/mac-os-x/accepting-always-on-facetime-calls/

share|improve this answer

Rather than deleting the key entirely, try setting it to an empty array:

defaults write com.apple.FaceTime AutoAcceptInvitesFrom -array-add nil
share|improve this answer
    
Thanks for the suggestion, unfortunately.. no change. –  Jonathan van Clute Nov 29 '12 at 5:19
    
Hmm. Perhaps try turning FaceTime fully off, quitting the app, making the change, then restarting FaceTime? –  robmathers Nov 29 '12 at 5:22
    
Interesting idea, I did go ahead and turn facetime off altogether and obviously that worked... but is a little extreme. I'll try making the change now that it's off, turning it back on, and see what happens. –  Jonathan van Clute Nov 29 '12 at 19:27
    
Sadly, no change from that at all. =( –  Jonathan van Clute Nov 29 '12 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.