Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The remote screen sharing feature of OS X is extremely convenient. I can access my office machine from home when I need some software that can only be installed on on-campus computers.

However, I noticed that if I log in to the office machine through screen sharing, everything I see on the shared screen is also mirrored on the machine's physical screen. Logging in using screen sharing unlocks the machine's physical keyboard and mouse as well.

Is it possible to avoid this security risk if someone can see or manipulate my Mac while I am not in the office?

Is it possible to access a remote computer through a graphical interface (not terminal) without exposing directly that machine to anyone who is in the office at that time? Of course they could steal the machine, but I don't want them snooping on grades or email or whatever when I unlock the screen remotely to access the Mac.

share|improve this question
    
Have you tried using LogMeIn? I haven't personally used it since I don't have more than one mac, but a lot of my coworkers have used it and found it very useful. –  rm -rf Feb 1 '13 at 1:32
    
@rm-rf Haven't heard of it before, will give it a try. –  Szabolcs Feb 1 '13 at 2:34

1 Answer 1

Yes - there are several ways around this.

The free, but less elegant solution is to make a second account on the Mac you wish to keep private. Set the machine to boot to that user and use Fast User switching to switch to your account.

Then when you log in - it will ask if you want to share the dummy account's screen or make a second virtual (and not drawn on the monitor) screen.

Alternatively, buy Apple Remote Desktop and use the "curtain mode" where it obscures the screen to hide what the remote operator is doing.

share|improve this answer
    
When I connect via the first method, the screen comes on and it prompts for the alternate user's password. After a few seconds it times out and goes back to sleep, but then wakes up again any time there is activity in the VNC session. Aside from alerting anyone in the room of activity, this also could cause wear on the backlight. Is there some way to disable this? –  Michael Jan 5 at 5:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.