Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a dual-screen setup, which works fine, but there's one annoyance, the window shadows.

If I maximize a window on one screen (or just make its edge touch the edge of one of the monitors), the shadow from that window "crosses" the screen and goes to the other one, creating a useless visual effect which just looks weird, since the monitors are not exactly touching, so the shadow has no usefulness or relevance there.

Is there a way to disable it (but not disable all window shadows)?

share|improve this question
    
if only fullscreen was remotely useful on dual monitors :( –  Agos Nov 28 '12 at 21:19
2  
That bugs me too! I think the only "official" answer is to wait for Mavericks, which supposedly lets you have multiple fullscreen apps on multiple monitors... –  daGUY Jul 22 '13 at 2:02
add comment

4 Answers

up vote 1 down vote accepted

In OS X Mavericks there no longer are cross-screen shadows. You can get this system update from the App store for free.

share|improve this answer
add comment

The shadow crosses over because the computer treats the displays as one long desktop with no space between. So if you had one short-wide monitor, it would make sense to have that shadow where it is.

There are ways to adjust the size of your display, so perhaps you could do this on one of your monitors to create a "dead zone" between, i.e. a little strip of desktop that neither screen displays. I've never tried this, so no guarantees. Otherwise, simply disable shadows altogether.

share|improve this answer
1  
I know why it happens / how it's coded, that's not the point... I don't know of / think there is a way to make a dead zone. –  houbysoft Jan 8 '13 at 15:52
    
@houbysoft If you were to make a dead zone, it would need to be at least 12 to 15 pixels wide as that's the visible range of the shadow I can measure on a light background screen. If you don't mind bad puns, I've crafted a non-answer below to report this as a bug to Apple which seems the pragmatic / long term way to address this odd edge case. –  bmike Sep 6 '13 at 22:11
add comment

No - but if you feel strongly that Apple should fix this edge case, you could file a bug report and post the radar number. I'd be glad to duplicate your efforts to agitate and have enough light directed to this issue to remove the shadow.

share|improve this answer
add comment

I use an app called ShadowKiller to turn off all window dropshadows. It was discontinued, but it still works with Mavericks. I can put a link in if this is what you want.

share|improve this answer
    
Hmm I like the other shadows, but thanks anyway –  houbysoft Oct 28 '13 at 5:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.