Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Error message "could not unmount disc"

Only tried Time Machine one day with new Snow Leopard install on MBP. Have been happy with CCC & want to use the space for a bootable CCC clone.

Time Machine won't let go of the space!!!

share|improve this question

1 Answer 1

If there is nothing else on this particular hard drive that you wish to keep, you can pick the "Partition" section in Disk Utility and repartition the whole drive to your liking rather than simply delete the Time Machine partition. You may have more luck with this than with editing the existing partitions. However, given that it's telling you it can't unmount the disk, Disk Utility may not let you do this either. You can most likely get around this by booting from your Snow Leopard installation DVD and using Disk Utility to repartition the external drive (careful, not your internal drive!) from there. Using the recovery system on the Snow Leopard DVD will avoid anything (like Time Machine) keeping the disk "busy" when you want to partition it.

share|improve this answer
    
Thanks cablesm - I recently purchased a retail Snow Leopard install disc on general principles and it's good to know that it actually HAS a recovery system. I solved the Time Machine problem by repartitioning the whole drive - decided I really had more backup than I needed. –  sharron Sussman Dec 25 '12 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.