Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having a sound output issue on my mac when both my Apogee Duet 2 and Logitech H540 headset are connected to my Macbook pro at boot.

Every time I restart my mid-2012 Macbook Pro my volume control icon in the menu bar is greyed out. If I unplug the Logitech H540 headset and reboot the volume control is solid (dark) and everything works fine. But when both devices are connected (which I need them to be), the volume control is grayed out so I can't make any adjustments from the menu bar.

The H540 headset is Mac compatible and doesn't require/have any drivers. This is a pretty annoying issues because I need to open my sound preferences and switch from the Duet USB output device to another device and then back to the Duet USB device to get things working properly again.

I have my MBP connected to an external Thunderbolt display, and I'm also using a USB hub for some extra USB ports. I always leave the Duet 2 connected to one of the MBP's USB ports, and I've tried the H540 headset in the Display USB's port, Hub's USB port, and connected directly to the MBP. Neither of those three ports made a difference on a reboot.

Is there some way I can delay the headset from connecting at boot? Maybe set it to delay by 30 seconds or something so that the Duet 2 becomes and main sound output and after 30 seconds the H540 is recognized as an additional sound output device?

Do I have any other alternatives or things I can try?

share|improve this question
    
If you're not running 10.8 you can use the free SoundSource program from Rogue Amoeba to quickly switch input and output devices for your Mac from the menu bar. Unfortunately it's not Mountain Lion compatible. –  Ian C. Nov 26 '12 at 14:10
    
@IanC. - Thanks for the reply. Unfortunately, I am running 10.8.2. But even if that did work, it's not much faster then using my keyboard shortcut in Alfred to open Sound Preferences and change it there. –  Kris Anderson Nov 26 '12 at 20:48
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.