Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried numerous ways to fix this problem :

  • Clean uninstall and re-install of Office 2011
  • Download individual updates
  • Download older Office updates

I always stop at "Destination Select" step of installation, where a small yellow triangle with an exclamation mark appears on top of the harddisk image. Saying that A version of the software required to install this update was not found on this volume.

I had Microsoft Office 2011 running perfectly before, but after deleting it and reinstalling it later, the whole problem started occuring.

I can install office 2011 14.0.0, 14.1.0 and 14.2.0 individually. However I cannot update them to any versions in between, including the full versions (14.0 to 14.1 or 14.1 to 14.2).

Oh and also, I sometimes get this error when I tried installing BUT word runs fine afterwards, although installation fails.

enter image description here

Would like to hear some advice. Thank you

I am not sure if this may cause it, but I have two-sided printing package installed :

The option is always there even after uninstalling and reinstalling, but I don't think this might be causing the error right ?

share|improve this question

Quit all Office applications, and move and from ~/Library/Preferences ... and any MicrosoftRegistrationDB .plists & the MicrosoftRegistrationDB.plist.lockfile from ~/Library/Preferences/ByHost to the desktop.

You may have to input your password for some of this. Start up an Office app again and see if this helps. The applications rebuild their preferences files. You may have to enter your registration code again.

share|improve this answer
I found - and one MicrosoftRegistrationDB.plist in Preferences ... I couldnt find any lockfile or Microsoft related items in ByHost. Anyway, I tried running Word after I removed those files, and I still got that error. – Render Nov 25 '12 at 14:09

Not sure of this particular error, but it seems like there's something wrong with installation media rather than your computer. It also sounds like you're trying to use an update package rather than a full install package.

Try downloading Microsoft Office again from Digital River. Microsoft provides mirrors for a copy of office online for Macs without optical drives. You'll need a valid license key to download it: or more direct link for the US:

Alternatively, you can download the trial version of Microsoft Office and enter the product key.

share|improve this answer
Already tried downloading a fresh new digital copy, installation fails. Check this article… – Render Nov 30 '12 at 10:31
up vote 0 down vote accepted

The only way to fix my problem was to get an already updated standalone version 14.2.5

share|improve this answer
Render -where did you get that? – OldGreg Dec 26 '12 at 23:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.