Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am using Macbook Air with OS 10.8.2. I bought my MAC from the US, and then moved to another country. Therefore, I had to change my keyboard language.

The problem is the keyboard layout is not the same. For instance when I type:

Shift + 9 it is supposed to show '('. But instead it shows ')'

There are a lot of similar shortcuts.

What I want it when I type Shift + 9 on my keyboard, I want to show '(' which is the same character that is written on the physical keyboard.

I want to reassign characters to these shortcuts.

I tried a software called Ukelele, but could not get it to work well for me.

If you have used Ukelele before, please let me know how can I do it step by step.

Otherwise do you have any other solutions for me?

share|improve this question
    
What language did you change your keyboard to? –  Tom Gewecke Nov 25 '12 at 15:43
    
PS and why did you need to change the keyboard exactly? Sometimes you can type the special characters needed for other languages very easily from the US layout and avoid all the mismatches with the printed keys. –  Tom Gewecke Nov 25 '12 at 16:03
    
@TomGewecke I don't know why it is important to know the language. Anyway I changed to Turkish. Because I need to use some turkish letter that don't exist in US keyboard. –  SNaRe Nov 25 '12 at 21:24
    
I think you can type all those turkish letters while keeping all your normal shortcuts the same by using the US Extended Keyboard layout. That would be an alternative to creating a custom layout via Ukelele. –  Tom Gewecke Nov 26 '12 at 13:11
add comment

2 Answers

If the manual provided with Ukelele is not sufficient, you can ask for help with specific problems at the users group

https://groups.google.com/forum/?fromgroups#!forum/ukelele-users

It might be easier to just use the US Extended layout. Shortcuts for Turkish special characters are

option c, then c ç
option b, then g ğ
option w, then i ı
option u, then o ö
option c, then s ş
option u, then u ü

PS Have you tried the Turkish Qwerty layout (instead of Turkish Qwerty PC) in system prefs/language & text/input sources? It may also do what you need via the option keys while keeping the usual other shortcuts.

share|improve this answer
    
The problem is not letter. Problem is characters actually. I just want them to use them as they are on keyboard. When I change my keyboard to Turkih Qwerty PC letters are in difference position –  SNaRe Nov 27 '12 at 21:28
    
@SNaRe Then why don't you use Turkish Qwerty instead of Turkish Qwerty PC as I suggested? –  Tom Gewecke Nov 28 '12 at 13:09
add comment
  1. Open Ukelele and Choose File > New Based on Current Input Source
  2. Edit the layout and save it as a bundle to /Library/Keyboard Layouts/. Keyboard layouts in the user library aren't selected by default in password dialogs. The popovers shown when holding keys don't work with normal keylayout files.
  3. Log out and back in
  4. Enable the input source in System Preferences

Applying changes to a keylayout file requires logging out and back in after for example running touch /Library/Keyboard Layouts/.

You can disable the default layouts by removing them from ~/Library/Preferences/ByHost/com.apple.HIToolbox.*.plist and logging out and back in.

Another option would be to use KeyRemap4MacBook.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.