Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 15-inch Macbook Pro with Retina Display that doesn't work with my USB 2 hard disk. It doesn't mount, doesn't show up in Disk Utility, and doesn't even show up in System Information in the USB section.

This hard disk works fine on my Ubuntu desktop, and it worked fine on my previous Macbook Pro (2009 model). It doesn't work on my new Macbook Pro, but another disk does.

This is a bus-powered drive. I tried rebooting my Mac, and plugging into a different USB port. The LED comes on when I plug it in, but that's it. If I put my ear to the disk, I hear mild clicking sounds (but I am not worried about data loss since the disk works great on my other machines, every time, without the clicking sound).

Any idea what I can try? Use an AC power adapter? Thanks.

share|improve this question
    
And you're using a normal USB2 cable (as opposed to a USB2-compatible cable that shipped with a USB3 device)? –  username Nov 24 '12 at 22:15
1  
I've experienced the same problem with a Western Digital Passport drive. It works fine in other computers but not in my mbp. The port doesn't deliver enough power for it. What you could try is a AC powered USB hub. –  Hoshts Nov 24 '12 at 22:59
    
Sorry for the late answer, @username, but I tried multiple USB 2 cables (there wasn't one that shipped with the disc as far as I remember), and the problem occurs no matter what cable I use. Two of my external hard discs also support a Firewire interface in addition to USB, so I purchased a Thunderbolt to Firewire adapter to get them to work. Firewire and Thunderbolt supply enough power, as I understand. –  Kartick Vaddadi Aug 23 at 4:06

2 Answers 2

up vote 0 down vote accepted

It definitely sounds like its not getting enough power. Not all USB ports on all machines deliver the same power.

share|improve this answer

Try using a USB - Y Cable! As the others have said... It appears the drive is not getting enough power.

Example, http://eshop.macsales.com/item/OWC/USB3AYMBPB/

I realize that is microusb but they make y cables with USB on all the ends.

Goodluck! :)

share|improve this answer
    
I purchased one, but it didn't work. Thanks for the tip, anyway. –  Kartick Vaddadi Aug 23 at 4:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.