Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been playing Crysis 2 and Skyrim on my Retina MacBookPro (10,1) for months now. The two games used to run super smoothly even on nearly maxed out settings. This laptop has an Nvidia GeForce GT 650M graphics card inside, it runs great.

But I recently replaced my Windows 8 consumer preview with the retail copy, and since then, 3D games lag in this odd way, no matter what the graphics settings. Every second Skyrim and Crysis alternates between running smoothly and lagging. It's a cyclical lag that comes and goes like clockwork. I can turn the graphics down to 800x600 with no antialiasing and low texture quality, and it runs much smoother on the "up" motion of the cycle, but every second it moves back into this lag spike.

I've tried installing beta graphics drivers, re installing the operating system, re installing the bootcamp support software, and freeing up space (I have about 20 GB free). I can't figure out what suddenly caused this other than some obscure difference between the consumer preview and the retail version.

What can I try? Is my video card failing? Are there some other drivers I can install? This isn't normal lag from maxing out the card, it

share|improve this question
    
If I'm not mistaking, there are no official Bootcamp drivers yet for Windows 8. –  Gerry Nov 24 '12 at 11:34
    
I suspect the reason is that there are no drivers for Windows 8 yet that enable use of the dedicated GPU. You're stuck with the Intel GPU, which is extremely slow compared to the Nvidia one. –  pmjordan Nov 26 '12 at 15:18
add comment

1 Answer

I had something similar happen to me recently. Suddenly, game performance went down pretty badly, not only on Windows, but on OSX as well.

Reseting the SMC seems to have corrected the issue.

Here are instructions on how to do it: http://support.apple.com/kb/HT3964

Hope it fixes your problem, if you haven't yet found a solution.

share|improve this answer
    
That is interesting. I would not have expected that to work. –  daviewales Feb 13 '13 at 1:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.