Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I tried to enable Calendar sync at Settings > iCloud > Calendar and a message says "Activating Calendar sync" but it ends up in Home screen with no changes. When I go again to iCloud setting I see Calendar option is not enabled.

Another problem I found is that I can not invite other people to appointments. It seems iCloud is not working for my Calendar.

How can I enable iCloud Calendar syncing?

share|improve this question
add comment

1 Answer

Try removing the iCloud account from your iPhone, and then adding it back. This has solved a number of my own iCloud-related issues in the past.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.