Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since I upgraded to Mountain Lion it happens to me every day when I enter the screen saver while having lunch it tries to restart the computer.

I don't have any clue why this happens. If there is some process running and OSX can't automatically quit it, OSX will tell me that it couldn't restart. But if there's no process like this running it will restart.

I don't really want this behaviour and searched in system settings as well in the Console in order to see why this might happen but I don't have a clue as of why.

OSX Mountain Lion 10.8.2 - MacBook Pro 15" Late 2011

share|improve this question
    
Are you using a Flash-based third party screensaver or one of those which came with your Mac? –  GhostLyrics Jul 2 '13 at 15:14
    
I'm using one which came with the mac (The random one). –  Michael Weibel Jul 2 '13 at 18:56

2 Answers 2

up vote 1 down vote accepted

Ok well. After getting more and more annoyed, I finally figured it out. Apparently I enabled the automatic logout after 60mins of inactivity in the security settings. I really don't know why/when I enabled this and wouldn't consider myself a noob ;) For anyone else looking for a howto on this: http://support.apple.com/kb/PH4014 (I found this page and thought: that must be it!).. It was.

share|improve this answer
    
It almost appears that Mavericks adjusted this setting. I know I would never enable this setting and yet mine was enabled as well. Thanks for this. –  Peter Jan 27 at 15:22

Not sure how to get rid of it - but this is an alternative (that I think is a lot better). Go to Settings > Deskop etc > Screensaver change it to your macs name/ the text with the apple logo - and then quit settings. After that go to Applications > Utilities > Keychain Access and go to Keychain Access(finder bar) > Preferences and find and tick where it says show in finder bar - a padlock should appear in your finder bar. Click that, and click lock screen and it will lock - and prompt you for a password when you go to log back in - it also shouldn't restart your mac (check your energy saver preferences pane)

share|improve this answer
    
Providing a way to instantly start the screensaver doesn't answer the question. –  Jawa Aug 7 '13 at 10:38
    
I actually always lock the screen using alfred and as a consequence of locking the screen, it displays the screen saver. –  Michael Weibel Aug 7 '13 at 11:11
    
Have a look in Activity Monitor and find the list of running (non system) processes - can you post a list? –  belly114 Aug 8 '13 at 18:00
    
And have you checked Energy Saver Preferences??? –  belly114 Aug 8 '13 at 18:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.