Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

So I was just using my MacBook Pro with an external display last night and it was working beautifully. For some reason, though, today it isn't working at all. I have a TB-to-HDMI cable which is hooked up to an HDMI-to-DVI adapter. I have just tried it on an HDMI tv and have gotten nothing except a "Not supported mode" and a mouse flicker. By the way, it's not just the tv and monitors not working. In the System Preferences it doesn't show any other displays or an option to extend or mirror like usual. I will be getting another cable tomorrow to see if that is the problem.

An important question that I have and what I am most concerned about is that I have gfxCardStatus installed and when I tried using my external display today I forgot to turn it off of "Integrated only". Do you think that could have broken something since external displays require the other GPU? Sometimes when I plug in the cord gfxCardStatus shows it going into the AMD GPU but then if I look under dependencies it says "None" (it usually said "Extended Display").

On very very rare occasions when I unplug the cord I will get a blue screen flash like it is changing display settings.

Some things I have tried:

  • Wiggling cord
  • Messing around with gfxCardStatus (even turning it off)
  • Changing settings in Energy Saver PrefPane
  • Clicked on "Detect Displays" many times
  • Resetting PRAM
  • Resetting SMC

Another thing is that I just recently got my logic board replaced so I wouldn't think that would be the case but unfortunately their 30-day repair warranty is up.

One more thing that I have found while scouring the internet is I came across a picture of someones System Report for Graphics and at the bottom of the read-out it says:

Display Connector: Status: No Display Connected
but mine doesn't say that (I don't know if it used to either).

What are some of your thoughts? I am really hoping it is just the cord.

EDIT: Just tried my Xbox into my HDMI-DVI adapter with the monitor and it worked so that rules that out. It has to either be my cord or my computer

share|improve this question
    
Have you tried going to Display preferences and holding down Option key to reveal the Detect displays button and clicking it while the display is hooked up? –  onik Nov 22 '12 at 9:19
    
Yes I have (I'll add that to the list). It appears to do nothing at all. –  adamk33n3r Nov 22 '12 at 9:25
add comment

2 Answers 2

You need to switch to discrete graphics in gfxCardStatus (or dynamic switching) for external display support. Also make sure you're running the latest version by running “Check for Updates…”. (Your cable is likely just fine.)

share|improve this answer
    
I have done this. If you re-read my post I say that it says it's switching to the discrete GPU. And yes...everything is up to date. –  adamk33n3r Nov 22 '12 at 10:13
    
Sorry, must have overlooked this, you're right. Can you test with another adapter or cable combo? –  MacLemon Nov 22 '12 at 10:51
    
Yes, like I said I'll be getting another cord today...or maybe tomorrow...to test it out. –  adamk33n3r Nov 22 '12 at 17:26
add comment
up vote 0 down vote accepted

It was a faulty cable. Just got a new one and it works beautifully. The reason why I posted here was basically just to see if the gfxCardStatus had anything to do with it. But thank you all for your help

Peace

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.