Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The fix does not stay, guess I'll wait for Apple to releases a fix.

It usually shutdown in 2,3 seconds while I was on Lion. I upgraded to ML recently and this happened.

In launchd-shutdown log, I found this

20006079                1      17        Exit timeout elapsed (20 seconds). Killing
20008561                1 65        Exit timeout elapsed (20 seconds). Killing

Things I have tried but no luck:

  • I have reset PRAM
  • clear kext-cache. it works at first shutdown only though.

Any idea how to fix this!?

share|improve this question
Could you close all your running applications and run ps -ax from the Terminal (to list all processes running)? – Ben Mordecai Jan 5 '13 at 22:31
THe list is rather long, I pasted it to pastebin here – Tuan Anh Tran Jan 6 '13 at 3:00
I didn't find anything that looked particularly out of the ordinary in that paste. Do you have the ability to backup and deactivate any software licenses and perform a clean installation? If so you could try to operate from the clean installation for a few days to see if the problem comes back. This way you can rule out a hardware problem. – Ben Mordecai Jan 6 '13 at 3:12
I tried a clean install before on my Air. Doesn't fix it though. Same thing happens with the new Retina MBP. – Tuan Anh Tran Jan 6 '13 at 4:02
Unfortunately, at this point there are pages and pages of discussion over this issue and everyone who seems to resolve it ends up resolving it for a different reason.… – Ben Mordecai Jan 6 '13 at 4:06
up vote 1 down vote accepted

Take a look at the following threads:

In short, it was recommended to: "removing items from Login Items for the user account and adding them back one at a time while testing restart/shutdown. Also, clearing out the ~/Library/Saved Application State folder and the System/Library/Caches folder and making sure your ML volume is selected as the volume to boot from in System Preferences / Startup Disk."

Also, maybe you have Dropbox/Google Drive/Software Update that runs in the background?

Another thing that mentioned was to uncheck "Reopen windows when logging" when shutting down for quick shutdown times.

Can you tell us which applications you think might cause problems?

share|improve this answer
- The problem is with shutting down so i don't see how login apps can affect this. Anyway, I have just ~ 7 logins app. - Dropbox isn't syncing when I shut down but problem's still there. - I have only 1 Volumes ML, no external drive connected when shutting down. - Already clearing Saved App State and Cache, also I never checked "Reopenn window when logging" – Tuan Anh Tran Dec 30 '12 at 12:20
I strongly recommend removing all of the 7 login apps and then trying to shutdown - it was recommended several times by other people who claimed it fixed their slow shutdown times.(I understand that it doesn't seem related, but indeed it was recommend). – Anonymous Dec 30 '12 at 12:25
tried it, still doesn't fix the issue though. – Tuan Anh Tran Dec 31 '12 at 3:37
I guess Apple is gonna have to fix this though. You deserve to get the bounty. Thanks a lot! – Tuan Anh Tran Jan 5 '13 at 13:23

I had the same problem and solved this by freeing more disk space on my Mountain Lion HD. Problem appeared with less than 50GB free space on the 500GB system disk. Now solved with 100GB free space.

share|improve this answer
my Mountain Lion SSD got like 210GB++ free space so I guess it's not the problem. – Tuan Anh Tran Jan 1 '13 at 12:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.