Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Last week my OS X Calendar stopped syncing to Google Calendar. Past events are still there, but new events aren't pushed to Google anymore.

I already tried deleting Calendar's/iCals Cache and Settings, removing the Google Calendar entirely and adding it back again. No success so far.

Does anybody know about a way to debug CalDAV syncing on OS X? Is there a issue with Google's servers?

Any help is appreciated.

share|improve this question
1  
You're not alone. I'm having the same problem. I'm getting a 404 response from the CalDav URL Calendar uses to sync up with Google. –  Ian C. Nov 23 '12 at 17:49

3 Answers 3

I started encountering a similar problem with my Google for Business account last week. Mail.app was okay but Calendar refused to sync, returning the error message that "Your calendar URL is not a location that supports this request." every time Calendar tried to sync.

The solution was delete the account completely from System Preferences -> Mail, Contacts & Calendars. Generate a new one-time password for the account (I use two-factor authentication on all my Google accounts). And the re-add the account in that System Preferences pane.

All is well now after doing this.

share|improve this answer

Note this problem occurred for me after changing my Google password.

On starting Calendar (a week or two after changing my password) it asked me for my password, as it couldn't access my Google account [expected behaviour]. I gave it my new password, and it seemed happy. HOWEVER the problem still remained.

The fix is definitely like the other poster mentioned, although you don't need to re-add the account, you only need to change the password in System Preferences > Mail, Contacts & Calendars.

To check if it's worked you will need to force a re-sync in iCal. Go to Calendar > Preferences... > Accounts > Google CalDAV > Account Information > Refresh Calendars: Every minute. Now wait a minute or so and the new events should be added. You can change this refresh rate back to your preferred setting afterwards.

This worked for me and i hope it works for anyone else who stumbles upon this thread :)

share|improve this answer

I unchecked and rechecked the "Calendar & Reminders" option under the "Mail, Contacts & Calendars" preferences pane for my affected Google account. That seems to have done the trick so far (without having to delete and recreate my account)… I manually refreshed the affected calendar, and it updated without complaint.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.