Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My computer doubles as a server, so I leave it turned on and not asleep, but logged out, most of the time.

In 10.6, if I logged out of the computer for an extended period of time, I could log back into it without touching the mouse or without the screen having come on yet by pressing any key to get rid of the screen saver, then typing my password and hitting return.

In 10.8, if I log out of the computer for a short period of time then this is still possible; when you log out, the keyboard focus (blinking cursor) is on the password field. However, if I log out for a long period of time - I don't know how long exactly, maybe just enough for the display to turn off - then it doesn't work; after waking the screen, the keyboard focus is nowhere. The only way I can log in again is by using the mouse to click on the password field, which puts focus back so I can type there.

For reasons too complicated to go into, this is highly annoying to me and I would like to be able to login using the keyboard only (without using a mouse or looking at the display). My questions:

  • Is this standard behaviour or something I have set up wrong somehow?
  • Is there some key combination I can press to focus the login field?
  • Is there a setting that will mean the login field always stays focused?

By the way, I only have a single account on the computer (that is visible on that screen, I mean).

share|improve this question

3 Answers 3

up vote 5 down vote accepted

I have also been bothered by this and some trial and error led me to discover that the login screen keyboard focus problem is not caused by the display turning off. Setting the display to never sleep in System Preferences revealed that there is a screen saver that appears when the computer is left idle at the login screen. The login field retains focus until the screen saver appears, and when the screen saver goes away, the field no longer has focus.

This screen saver is not controlled by the screen saver settings in System Preferences, so I have not found a way to disable it. However, I did find a setting that I use as a workaround. There is a Terminal command that can be used to set the amount of idle time before the screen saver appears. I just set it to a number of seconds that is higher than the amount of time I am usually away from the computer. To change this setting you can open the Terminal (in /Applications/Utilities) and run the following command:

sudo defaults write /Library/Preferences/com.apple.screensaver loginWindowIdleTime 10800

Of course you should replace the 10800 with a number of seconds that will work for you. This command is documented by Apple Support in the article "Configuring a screen saver to run at the Login Window."

http://support.apple.com/kb/HT4625

The article refers to OS X v10.6 specifically, but I used it on Mountain Lion 10.8.

share|improve this answer
1  
Thanks - this is exactly the solution! I set it to a month's worth of seconds, and it seems to be working (tried it overnight). –  sam Dec 20 '12 at 0:35

Have you tried hitting the Ctrl, Option or Command keys to wake the computer?

share|improve this answer
1  
Yes, I normally use Ctrl and I think I tried pressing all those others too. The display wakes fine whatever key I press, and the password field is displayed, but it doesn't have the blue outline indicating keyboard focus, or the blinking cursor (both of which are there before the display sleeps). You have to click on it with the mouse to put focus back. –  sam Nov 21 '12 at 0:18
    
I was able to cycle through the input by using the tab key –  Mark Cohen Dec 17 '12 at 20:33
1  
Just to confirm, the tab key does not do anything in the situation I'm referring to. –  sam Dec 20 '12 at 0:55

At login there is a list of names (if multiple people are set to use the computer) and guest, type the first letter of the name that you want to login with, then hit enter. You are now able to enter your password.

i.e. if your name is Sam Jones press s then enter and you are ready to go.

share|improve this answer
    
The problem though is when the login window is set to not show the list of users, only username & password text boxes. –  Mr Rabbit Nov 1 '13 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.