Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Both iTunes on Windows 7 and the Apple TV 3 are updated to the latest versions. My PC is connected to the router via Cat 5 and the Apple TV is connected on wireless. I can AirPlay with my iPad or iPhone. I've had this work just fine before with other computers. Home sharing is enabled on both devices and connected to the same account with the correct password. I can't figure out what's going on.

share|improve this question
    
Is iTunes running and are both the computer and AppleTV using the same networking subnet? –  Gerry Nov 16 '12 at 6:28
    
Yep, everything is set up as it SHOULD be for it to work. Like I said, it has worked before. –  Andrew Burgess Nov 16 '12 at 6:56
add comment

3 Answers 3

The problem could be with your firewall. You should check the firewall software you use and open relevant ports. Some firewalls actually have predefined rules for the services, but for most you'll have to define them manually.

Most commonly the services used are named mDNS or Bonjour sharing. If these aren't found, you can find a list of relevant ports here and add them manually.

share|improve this answer
add comment

I had a similar issue with my Mac and Apple TV

I was able to exchange it at a Apple store after creating a case with Apple support. Info on the exchange program here.

For me, everything worked on the network except for Home Sharing on the Apple TV. It passed all tests and otherwise worked fine. In my case, restarting iTunes would 'enable' Home Sharing access from the Apple TV for a little while, then it would drop again.

Good luck.

share|improve this answer
add comment

In Apple TV, Go To Settings > General and hit restart - beyond that I think Apple Support would be a good way to go

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.