Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to design a font containing symbols for internal use in our organisation.

I've created a font using this tutorial, and I've assigned a symbol to the unicode position 0xF600. This lies within the 'Private use area', and doesn't appear to have any fonts which are supplying it.

I've created my font and installed it. I've tried with the font in either ~/Library/Fonts or /System/Library/Fonts.

If I insert this character () in TextEdit or any system text box I get either a box or some kind of mark contained within a box. Either way, not my character.

If I manually set the font to my font, the character is displayed.

However, I notice that other characters don't work like this. If I'm using Helvetica, and I insert a Chinese character, the symbol is taken from a different font which can display that glyph. So clearly there's a mechanism to fallback to a font which contains the character.

Are some fonts blessed by the system? How would I get my font to be the fallback?

EDIT: I've tried clearing the font cache with sudo atsutil databases -remove, didn't affect it.

EDIT 2: After poking around a bit and doing some reading, there's a font called LastResort.ttf that is the final fallback for all the unicode characters, there must be a precedence set somewhere in the system, so that that is always last. I wonder where that is...

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

OS X normally will not display a character in the Private Use Area unless you manually set the font in the app. I understand this is intentional, since every font could have a different glyph at the same PUA code point, and it only makes sense to display something when the user specifies the font.

I think it should also work when the right font is selected via CSS or other markup in a document being read.

Some earlier versions of OS X did not have this "feature" and did display PUA stuff. I don't know how they chose which font to use when more than one had something at the code point selected.

share|improve this answer
    
Many thanks for your answer! I note however that there are a few symbols in the PUA that are displayed ordinarily (). Perhaps these are special cases? –  joerick Nov 29 '12 at 9:13
    
@joerick Yes, I think there a couple fonts which don't obey the normal rule and do show up for some reason. –  Tom Gewecke Nov 29 '12 at 13:28
    
Thanks! Got it working by putting my glyph at code point 0x10000, this is in the range 'Linear B Syllabary', which is currently empty. As long as a historical Greek font isn't installed in a future update I should be fine... !! –  joerick Nov 29 '12 at 14:47
    
@joerick That should work fine, these days I think all apps should support characters in that higher Unicode plane. If one has a problem, you could probably find an empty spot lower down somewhere. –  Tom Gewecke Nov 29 '12 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.