Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently installed VMWare Fusion and added Windows 7. Now when I right-click on a text file and choose Open With, there's an option to open with Notepad in Windows 7. This is not something I want enabled. How can I remove this choice?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

One solution is to install RCDefaultApp and change the file association for text files.

Another solution is to disable Windows application integration for that virtual machine. To do that open the virtual machine, go to the Virtual Machine menu and select Settings.... Change the settings for Default Applications. You likely want to uncheck Run Windows applications from you Mac's Applications folder

enter image description here

share|improve this answer
    
Looks handy, thank you. Unfortunately it appears that it's no longer maintained; at least one commenter notes it doesn't work with Mountain Lion. –  james.garriss Nov 15 '12 at 20:25
    
Hmm, I use it with Mountain Lion. –  HairOfTheDog Nov 15 '12 at 20:32
1  
Nice, @Hair. Changing the settings via Fusion is the right answer. I've been all through those settings, but didn't see that. Note that a reboot is required for the changes to take place. Thank you! –  james.garriss Nov 15 '12 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.