Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up my Macbook Pro (15" late 2008, if it matters) to quad-boot Lion, Snow Leopard, Windows 7, and Ubuntu 12.04 (using rEFIt). Everything worked fine for a couple months. Then my optical drive broke, so I disconnected it from the motherboard to prevent it from making noises every time I started the computer or woke it up from sleep. Now whenever I try to boot into Windows or Ubuntu, the computer hangs on a black screen.

A few things that I've confirmed are NOT the problem:

  • rEFIt: I tried booting into Windows using both rEFIt and the default Apple bootloader, and I get the black screen either way.
  • Corruption of the OS partitions: I have both Windows and Ubuntu set up to run in VMware Fusion, and they boot fine in that.

I'm wondering if the problem has to do with Windows and Ubuntu being set up to "expect" to have an optical drive, but that doesn't seem like it should be a problem, especially because the boot process for both stops at the same state before anything specific to each OS shows up.

Any ideas? And is something related to "expecting" and not finding an optical drive even a possibility?

EDIT: I re-connected the optical drive, and everything works fine again. (Also, the optical drive seems like it might have healed itself, or at least it's back to making the normal noise instead of the extra bad one.)

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.