Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Apple TV (3rd generation) doesn't connect to the internet any more because it doesn't succeed in getting the network time from my router.

I tried restarting, updating, resetting both – the Apple TV and my WLAN router (TP-Link 1043ND), I double checked the network time in my router, tried out an alternative firmware (DD-WRT), put down all security settings (no password), tried direct connection per cable (LAN) on Apple TV – but nothing worked:

I always get the screen that Apple TV tries to fetch the network time (I'm in Germany) – the manual selection of Berlin as time zone doesn't help.

It all worked a few weeks ago – after an update of the Apple TV Software it all went away ... my Apple TV got useless because it needs the correct time settings to connect to the internet.

Does anyone have an idea what I can do?

share|improve this question
up vote 0 down vote accepted

Downgrade to previous version (5.0.2).

Here's a description on how to do this from Apple:

share|improve this answer
What steps are needed to do this? We prefer answers that can be self explanatory - and most iOS updates are one way only. It's not clear Apple TV supports downgrade either. – bmike Nov 16 '12 at 20:46
Thanks Rene, this solved my problem! – CGee Nov 17 '12 at 11:47

My TP-Link router had problems with AppleTV. The iPad didn't see Airplay. I resolved it by following this Apple KB page on iOS and OS X: Recommended settings for Wi-Fi routers and access points.

share|improve this answer

I had this problem when I was at home at my parent's where their network connection was not super good. Super good being 10+ Mbit service with ping times to major internet switching hubs of 20 ms. Their ping times were 111 ms range and 1 to 3 % dropped packets most of the time when we measured communications to known good computers around the country.

We ended up restoring the Apple TV twice and leaving it connected to the network for two days. We let it sit for 12 hours after the first restore and the device wouldn't get time settings.

The second time, we just kept waiting and waiting and without any action or change on our part, it finally got a server and set the time.

It was frustrating as this was an Apple TV that had worked for me for over a year and it just didn't work despite it being so critical to even signing in to an Apple ID.

share|improve this answer
Waiting for so long wouldn't be a solution for me because I sometimes tend to turn off electricity in my room when I'm not home for a while – so I would have to wait this time again and again ... – CGee Nov 17 '12 at 11:44
We power off the Apple TV all the time, just it needs to be on to get that first sync and signed in. Once the clock was close, it doesn't seem to drift so badly. You will save time by keeping the Apple TV plugged in all the time as it does seem to use very low power at sleep. – bmike Nov 17 '12 at 18:04

The 5.1 upgrade caused issues with connectivity. Make sure you are using a wifi connection rather than hardwire. If the issue persists, restore your router and reconfgure.

share|improve this answer
Seems like you haven't read my question entirely: I have tried all of your suggestions already. None of em worked for me. – CGee Nov 17 '12 at 11:45

Edugeek had the answer when I had the same issue.

share|improve this answer
Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grgarside Jan 1 '14 at 18:17

I used a wired (Ethernet) connection instead of wireless and it worked for all updates. When I moved back over to wifi connection it remained ok

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.