Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When viewing a DFS share in OS X 10.7 or on a system that has been upgraded from 10.7 to 10.8 the sidebar is missing in finder.

However if a system has had a fresh install of OS X 10.8 the sidebar is visible in finder.

Is there a way to get the sidebar back in 10.7 or a system that has gone from 10.7 to 10.8?

share|improve this question
add comment

1 Answer 1

What type of volume you're viewing doesn't have an impact on the Finder's display settings. You can toggle the sidebar in any Finder window by going to View → Show/Hide Sidebar or pressing ⌥⌘S.

The reason you're seeing it on one machine and not the other is that it likely got toggled at some point for that folder and the setting stuck. Finder does store view settings per folder, although it can be a bit inconsistent in doing so.

share|improve this answer
    
The option was greyed out. Worked out the you need to show tool bar to be able to then show the side bar. But if the DFS share is unmounted and the mounted again the settings are dropped. This does not happen with normal SMB shares or a fresh install of 10.8. –  holz Nov 15 '12 at 3:49
    
Just tested a fresh install of 10.7 and the issue still occurs. –  holz Nov 15 '12 at 3:59
    
Hmm. You might want to try removing the .DS_Store files on the share. They store view information, it may be that one is forcing this behaviour. –  robmathers Nov 15 '12 at 4:03
    
There is no .DS_Store. You can not write to the top level DFS folder. I'm guessing there is a system default used for DFS folders, and because OSX cant write a .DS_Store to the top level DFS share it always uses the defaults. This default setting is then carried through to 10.8 when you upgrade. I have tested a SMB share that can not be written to at the top level and it does not exhibit this behaviour. –  holz Nov 15 '12 at 4:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.