Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've got a 15-inch MBP Retina. I am using both Thunderbolt ports to drive two third-party monitors via DVI.

Sometimes (at least 3-4 times a week) after the display goes to sleep when I walk away from my desk, when I return one of the monitors won't come back up. OSX acts like it thinks the monitor is still active - it appears in the arrangement dialog and windows are still positioned over there. But the monitor itself says it is not receiving a signal.

The only way I've found to fix this problem is to disconnect both Thunderbolt ports and reconnect them. Just reseating the one with the issue does not fix it.

Is there a way to prevent this, or at the very least, fix it without having to constantly unplug-replug both monitors?

share|improve this question
add comment

1 Answer

I have this same issue on my iMac 27" (Mid 2011) with one external DVI monitor. I took the iMac into the Apple store and the genius couldn't provide an answer to why this was occurring. I also tried using both Thunderbolt ports and the issue would happen on both. So for now what I did was to not let my iMac go into sleep mode. I set it to just have the display's go to black and when I activate the iMac the external display always comes back. Hoping a future update to Mountain Lion OS X 10.8 will fix this issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.